summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLin Ruoshui2019-03-22 19:34:25 +0800
committerLin Ruoshui2019-03-22 19:34:25 +0800
commitb3d553987dc14e0ae5abe5cd49025110c8fb430a (patch)
treead7983c2bc582fca84905e5ce202e0e32d2f6bb6
parent9d4ac65e1bd6f669e43d7ef0c4a2c8ed413a536e (diff)
downloadaur-b3d553987dc14e0ae5abe5cd49025110c8fb430a.tar.gz
chore: remove unused build methods deleted in upstream
- use native 64-bit build instead of multilib - remove unused cmake option about multilib library - remove lib32-sdl2 lib32-sdl2_mixer in build
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD43
2 files changed, 26 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc9ba5ffef19..a061cb639893 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,10 @@
-# Generated by mksrcinfo v8
-# Fri Jan 25 13:21:00 UTC 2019
pkgbase = devilutionx-git
pkgdesc = Diablo devolved for linux (git version)
- pkgver = r1066.be85b3f
+ pkgver = 0.3.1.r5.gf2e352fb
pkgrel = 1
url = https://github.com/diasurgical/devilutionX
arch = x86_64
- license = custom:The Unlicense
+ license = custom:
makedepends = git
makedepends = cmake
makedepends = gcovr
@@ -14,8 +12,10 @@ pkgbase = devilutionx-git
makedepends = lib32-sdl2_mixer
makedepends = nasm
depends = sdl2_mixer
+ depends = sdl2_ttf
+ depends = lib32-sdl2_ttf
+ depends = libsodium
provides = devilutionx-git
- conflicts = devilutionx-git
options = !strip
source = devilutionx-git::git+https://github.com/diasurgical/devilutionX.git
source = LICENSE::https://raw.githubusercontent.com/diasurgical/devilutionX/master/LICENSE
diff --git a/PKGBUILD b/PKGBUILD
index 3bfacb86ecf4..858ede8a3d54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,43 @@
-# Maintainer: LIN Ruohshoei <20455421+LinRs [dot] users.noreply.github.com>
+# Maintainer: LIN Rs <20455421+LinRs [dot] users.noreply.github.com>
pkgname=devilutionx-git
-pkgver=r1066.be85b3f
+_pkgname=devilutionx
+pkgver=0.3.1.r5.gf2e352fb
pkgrel=1
pkgdesc="Diablo devolved for linux (git version)"
arch=('x86_64')
url="https://github.com/diasurgical/devilutionX"
-license=('custom:The Unlicense')
-depends=('sdl2_mixer')
-makedepends=('git' 'cmake' 'gcovr' 'lib32-gcc-libs' 'lib32-sdl2_mixer' 'nasm')
+license=('custom:unlicense')
+depends=('sdl2_mixer' 'sdl2_ttf' 'libsodium')
+makedepends=('git' 'cmake' 'gcovr' 'nasm')
provides=("${pkgname}")
-conflicts=("${pkgname}")
-options=('!strip')
source=(
- ${pkgname}::git+https://github.com/diasurgical/devilutionX.git
+ "${pkgname}::git+https://github.com/diasurgical/devilutionX.git"
LICENSE::https://raw.githubusercontent.com/diasurgical/devilutionX/master/LICENSE
- )
+)
noextract=()
sha256sums=('SKIP'
'88d9b4eb60579c191ec391ca04c16130572d7eedc4a86daa58bf28c6e14c9bcd')
pkgver() {
- cd "$pkgname"
+ cd "${pkgname}"
( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}
build() {
- cd "$srcdir/${pkgname}"
- mkdir -p build && cd build
- export SDL2_LIBRARIES="-L${SDL2_LIBDIR} -lSDL2 -lSDL2_image -lSDL2_mixer -lSDL2_ttf"
- export CFLAGS="$CFLAGS -O0 -fbuiltin -g"
- export CXXFLAGS="$CXXFLAGS -O0 -fbuiltin -g"
- cmake .. \
- -DCMAKE_INSTALL_PREFIX=/usr
- make devilution
+ cd "${pkgname}"
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir -p build && cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
}
package() {
- cd "$srcdir/${pkgname}"
- install -vDm755 build/devilution "${pkgdir}/usr/bin/devilution"
- install -vDm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ cd "${pkgname}"
+ install -vDm755 build/"${_pkgname}" "${pkgdir}"/usr/bin/"${_pkgname}"
+ install -vDm644 LICENSE -t "${pkgdir}"/usr/share/licenses/"${pkgname}"
}