summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyndair2021-02-10 14:35:14 +0000
committerkyndair2021-02-10 14:35:14 +0000
commit7398ef98eda1b486c8075418c267c25e7e3fc0d6 (patch)
tree70b3f483267880a7494dbb23b5fd040f6ae47604
downloadaur-7398ef98eda1b486c8075418c267c25e7e3fc0d6.tar.gz
inital hellfire support in devilution
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD58
-rw-r--r--diablo1.desktop10
-rw-r--r--hellfire.desktop10
4 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eebf8b03f0df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = devilutionx-hellfire-git
+ pkgdesc = Diablo & Hellfire devolved
+ pkgver = 1.1.0.r978.g5d2af51d
+ pkgrel = 1
+ url = https://github.com/diasurgical/devilutionX
+ arch = i686
+ arch = pentium4
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = custom
+ makedepends = cmake
+ depends = sdl2_ttf
+ depends = sdl_mixer
+ depends = libsodium
+ depends = hellfire-data
+ provides = devilutionx
+ conflicts = devilutionx
+ conflicts = devilutionx-git
+ conflicts = devilutionx-hellfire
+ source = git+https://github.com/diasurgical/devilutionX.git
+ source = diablo1.desktop
+ source = hellfire.desktop
+ sha256sums = SKIP
+ sha256sums = 696de98c061387e2aee25dc9c9c5bedf468e53dab23ac37ee8afa8408fe5e424
+ sha256sums = 8c15c30c7818b4e7bb59b4505c6afc0fafd9e6410e97bf36b833e8d395820300
+
+pkgname = devilutionx-hellfire-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a3ac327c72a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: kyndair <kyndair at gmail dot com>
+pkgname=devilutionx-hellfire-git
+_pkgname=devilutionX
+pkgver=1.1.0.r978.g5d2af51d
+pkgrel=1
+pkgdesc="Diablo & Hellfire devolved"
+arch=('i686' 'pentium4' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/diasurgical/devilutionX"
+license=('custom')
+depends=('sdl2_ttf' 'sdl_mixer' 'libsodium' 'hellfire-data')
+makedepends=('cmake')
+provides=('devilutionx')
+conflicts=('devilutionx' 'devilutionx-git' 'devilutionx-hellfire')
+source=('git+https://github.com/diasurgical/devilutionX.git'
+ 'diablo1.desktop'
+ 'hellfire.desktop')
+sha256sums=('SKIP'
+ '696de98c061387e2aee25dc9c9c5bedf468e53dab23ac37ee8afa8408fe5e424'
+ '8c15c30c7818b4e7bb59b4505c6afc0fafd9e6410e97bf36b833e8d395820300')
+
+# update the package version to the current git version
+pkgver() {
+ cd "${srcdir}/$_pkgname"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+# compile devilutionX with Hellfire enabled
+build() {
+ cd "${_pkgname}"/build
+ cmake .. -DHELLFIRE=ON
+ make
+}
+
+package() {
+ # install game icons
+ install -Dm644 "${srcdir}/$_pkgname/Packaging/resources/icon.png" "${pkgdir}/usr/share/pixmaps/diablo-$_pkgname.png"
+ install -Dm644 "${srcdir}/$_pkgname/Packaging/resources/hellfire.png" "${pkgdir}/usr/share/pixmaps/hellfire-$_pkgname.png"
+ # install required font
+ install -Dm644 "${srcdir}/$_pkgname/Packaging/resources/CharisSILB.ttf" "${pkgdir}/usr/share/fonts/Charis/CharisSILB.ttf"
+ # install game documents
+ install -Dm644 "${srcdir}/$_pkgname/README.md" "${pkgdir}/usr/share/doc/${_pkgname}/$_pkgname-readme.md"
+ install -Dm644 "${srcdir}/$_pkgname/docs/BACKGROUND.md" "${pkgdir}/usr/share/doc/${_pkgname}/$_pkgname-background.md"
+ install -Dm644 "${srcdir}/$_pkgname/docs/CHANGELOG.md" "${pkgdir}/usr/share/doc/${_pkgname}/$_pkgname-changelog.md"
+ install -Dm644 "${srcdir}/$_pkgname/docs/CONTRIBUTING.md" "${pkgdir}/usr/share/doc/${_pkgname}/$_pkgname-contributing.md"
+ install -Dm644 "${srcdir}/$_pkgname/docs/debug.md" "${pkgdir}/usr/share/doc/${_pkgname}/$_pkgname-debug.md"
+ install -Dm644 "${srcdir}/$_pkgname/docs/mods.md" "${pkgdir}/usr/share/doc/${_pkgname}/$_pkgname-mods.md"
+ install -Dm644 "${srcdir}/$_pkgname/docs/TODO.md" "${pkgdir}/usr/share/doc/${_pkgname}/$_pkgname-todo.md"
+ # install devilutionX licenses
+ install -Dm644 "${srcdir}/$_pkgname/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/$_pkgname-license"
+ install -Dm644 "${srcdir}/$_pkgname/Packaging/resources/LICENSE.CharisSILB.txt" "${pkgdir}/usr/share/licenses/${_pkgname}/CharisSILB-font-license.txt"
+ # install devilutionX executable
+ install -Dm755 "${srcdir}/$_pkgname/build/devilutionx" "${pkgdir}/opt/${_pkgname}/devilutionx"
+ mkdir "${pkgdir}/usr/bin"
+ ln -s /opt/devilutionX/devilutionx "${pkgdir}/usr/bin/devilutionx"
+ # install launchers
+ install -Dm644 "${srcdir}/diablo1.desktop" "${pkgdir}/usr/share/applications/diablo1.desktop"
+ install -Dm644 "${srcdir}/hellfire.desktop" "${pkgdir}/usr/share/applications/hellfire.desktop"
+}
diff --git a/diablo1.desktop b/diablo1.desktop
new file mode 100644
index 000000000000..775e829d2554
--- /dev/null
+++ b/diablo1.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Diablo
+Comment=Action RPG from 1996
+Exec=devilutionx --diablo
+Icon=diablo-devilutionX.png
+Terminal=false
+Type=Application
+X-DCOP-ServiceType=Multi
+X-KDE-StartupNotify=true
+Categories=Game;RolePlaying;
diff --git a/hellfire.desktop b/hellfire.desktop
new file mode 100644
index 000000000000..278f5864ee54
--- /dev/null
+++ b/hellfire.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Hellfire
+Comment=Expansion pack to the 1996 Diablo
+Exec=devilutionx --theoquest --bardtest --barbariantest
+Icon=hellfire-devilutionX.png
+Terminal=false
+Type=Application
+X-DCOP-ServiceType=Multi
+X-KDE-StartupNotify=true
+Categories=Game;RolePlaying;