summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2017-06-27 18:36:49 +0200
committerCarsten Teibes2017-06-27 18:36:49 +0200
commit635fc20f0822a4b39325db9cb788ac02c737631e (patch)
tree4336c0f92bfb6f9b06d066c45e9a45a5791bdda8
parentdea1bbe035d5ab0288a6a0389e4334c4f3b0c80a (diff)
downloadaur-635fc20f0822a4b39325db9cb788ac02c737631e.tar.gz
[fix] Add patches to build with GCC7
Disable Guile for GDB (does not build) Fix ISL usage
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--devkitarm-add-gcc-patch.patch11
-rw-r--r--devkitarm-add-patches.patch35
-rw-r--r--devkitarm-use-in-tree-isl.patch22
-rw-r--r--fix-gcc-6.3.0-compilation-on-gcc-7.patch28
-rw-r--r--fix-gdb-7.12-compilation-on-gcc-7.patch32
7 files changed, 111 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8daf6f6006bc..ee322a1189a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -54,7 +54,9 @@ pkgbase = devkitarm
source = http://downloads.sourceforge.net/sourceforge/devkitpro/3dstools-1.1.4.tar.bz2
source = http://downloads.sourceforge.net/sourceforge/devkitpro/picasso-2.5.0.tar.bz2
source = devkitarm-skip-libs.patch
- source = devkitarm-use-in-tree-isl.patch
+ source = devkitarm-add-patches.patch
+ source = fix-gcc-6.3.0-compilation-on-gcc-7.patch
+ source = fix-gdb-7.12-compilation-on-gcc-7.patch
source = devkitarm.sh
source = devkitarm.fish
sha256sums = 6b142f265bc9c7fc9449f5b539198f140d231725b2ed0828749d8a1e0fad73ff
@@ -77,7 +79,9 @@ pkgbase = devkitarm
sha256sums = b54002b86e3a6005a204153d7567876f920a1a5c0a2bc288d95d98189ef0f5e3
sha256sums = 2af6d351b8b1d3c107ab31463eca8e73f88f201e580c448bfc71876f4ebe314d
sha256sums = 3ba88e36a690f45baf642afbb49bd40e7fc7fb53e3f2eb69b594057cd6071e6d
- sha256sums = df823a3344aa91ce8f2fa706c9918f95a99e71e0c65f0d281c8e59cef858280a
+ sha256sums = c525872f266457e2e8195781193fb59c302b6fb920ad7b1ed227b8f126395526
+ sha256sums = e7013af51af0cb1e088f7fc25576471076780bc97e05e7921fe819a3c87fce8b
+ sha256sums = bd61f5c2a9edcf899a1640d18ba0f858b4ecd800b6311e17e53838405a7b3748
sha256sums = 9448465b2de6b6aefc5e0a8404f780f737cb86b4b1280d653712271b892908f9
sha256sums = c4cc42b085be7c48f06f75c934e846a61749d9ba5e31ee463a03ba27a01c8afd
diff --git a/PKGBUILD b/PKGBUILD
index 62f74afce87e..bed685dbee92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,7 +48,9 @@ source=("http://downloads.sourceforge.net/sourceforge/devkitpro/buildscripts-201
"http://downloads.sourceforge.net/sourceforge/devkitpro/3dstools-$_3dstoolsver.tar.bz2"
"http://downloads.sourceforge.net/sourceforge/devkitpro/picasso-$_picassover.tar.bz2"
"devkitarm-skip-libs.patch"
- "devkitarm-use-in-tree-isl.patch"
+ "devkitarm-add-patches.patch"
+ "fix-gcc-6.3.0-compilation-on-gcc-7.patch"
+ "fix-gdb-7.12-compilation-on-gcc-7.patch"
"devkitarm.sh"
"devkitarm.fish")
sha256sums=('6b142f265bc9c7fc9449f5b539198f140d231725b2ed0828749d8a1e0fad73ff'
@@ -71,7 +73,9 @@ sha256sums=('6b142f265bc9c7fc9449f5b539198f140d231725b2ed0828749d8a1e0fad73ff'
'b54002b86e3a6005a204153d7567876f920a1a5c0a2bc288d95d98189ef0f5e3'
'2af6d351b8b1d3c107ab31463eca8e73f88f201e580c448bfc71876f4ebe314d'
'3ba88e36a690f45baf642afbb49bd40e7fc7fb53e3f2eb69b594057cd6071e6d'
- 'df823a3344aa91ce8f2fa706c9918f95a99e71e0c65f0d281c8e59cef858280a'
+ 'c525872f266457e2e8195781193fb59c302b6fb920ad7b1ed227b8f126395526'
+ 'e7013af51af0cb1e088f7fc25576471076780bc97e05e7921fe819a3c87fce8b'
+ 'bd61f5c2a9edcf899a1640d18ba0f858b4ecd800b6311e17e53838405a7b3748'
'9448465b2de6b6aefc5e0a8404f780f737cb86b4b1280d653712271b892908f9'
'c4cc42b085be7c48f06f75c934e846a61749d9ba5e31ee463a03ba27a01c8afd')
noextract=("binutils-$_binutilsver.tar.bz2" "gcc-$_gccver.tar.bz2"
@@ -109,7 +113,10 @@ END
buildscripts/build-devkit.sh
# use in-tree isl
- patch -Np0 < devkitarm-use-in-tree-isl.patch
+ # add patch to build gcc 6.3.0 on gcc >7
+ # disable guile for gdb
+ patch -Np0 < devkitarm-add-patches.patch
+
# isl needlessly wants automake-14, upgrading
autoreconf -Wnone -fi isl-$_islver
diff --git a/devkitarm-add-gcc-patch.patch b/devkitarm-add-gcc-patch.patch
deleted file mode 100644
index a993c74fdef4..000000000000
--- a/devkitarm-add-gcc-patch.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Naur buildscripts.old/build-devkit.sh buildscripts/build-devkit.sh
---- buildscripts.old/build-devkit.sh 2016-11-27 21:58:40.103228901 +0100
-+++ buildscripts/build-devkit.sh 2016-11-27 22:54:55.283172632 +0100
-@@ -243,6 +243,7 @@
- extract_and_patch binutils $BINUTILS_VER bz2
- extract_and_patch gcc $GCC_VER bz2
- rm -fr gcc-$GCC_VER/zlib
-+patch -d gcc-$GCC_VER -Np1 < "$SRCDIR/fix-gcc-5.3.0-compilation-on-gcc-6.patch"
- extract_and_patch newlib $NEWLIB_VER gz
- extract_and_patch gdb $GDB_VER bz2
-
diff --git a/devkitarm-add-patches.patch b/devkitarm-add-patches.patch
new file mode 100644
index 000000000000..ba133c748171
--- /dev/null
+++ b/devkitarm-add-patches.patch
@@ -0,0 +1,35 @@
+diff -Naur buildscripts.orig/build-devkit.sh buildscripts/build-devkit.sh
+--- buildscripts.orig/build-devkit.sh 2017-01-25 20:10:12.000000000 +0100
++++ buildscripts/build-devkit.sh 2017-06-27 18:11:47.033227074 +0200
+@@ -232,8 +232,11 @@
+
+ extract_and_patch binutils $BINUTILS_VER bz2
+ extract_and_patch gcc $GCC_VER bz2
++cp -ru "$SRCDIR/isl-0.16.1" gcc-$GCC_VER/isl
++patch -Np0 < "$SRCDIR/fix-gcc-6.3.0-compilation-on-gcc-7.patch"
+ extract_and_patch newlib $NEWLIB_VER gz
+ extract_and_patch gdb $GDB_VER bz2
++patch -d gdb-$GDB_VER -Np1 < "$SRCDIR/fix-gdb-7.12-compilation-on-gcc-7.patch"
+
+ if [ $VERSION -eq 2 ]; then
+ extract_and_patch binutils $MN_BINUTILS_VER bz2
+diff -Naur buildscripts.orig/dkarm-eabi/scripts/build-gcc.sh buildscripts/dkarm-eabi/scripts/build-gcc.sh
+--- buildscripts.orig/dkarm-eabi/scripts/build-gcc.sh 2017-01-25 17:51:43.000000000 +0100
++++ buildscripts/dkarm-eabi/scripts/build-gcc.sh 2017-06-27 17:51:30.771359311 +0200
+@@ -61,6 +61,7 @@
+ --disable-libmudflap --disable-libssp --disable-libgomp \
+ --disable-libstdcxx-pch \
+ --target=$target \
++ --with-isl \
+ --with-newlib \
+ --with-headers=../../newlib-$NEWLIB_VER/newlib/libc/include \
+ --prefix=$prefix \
+@@ -158,7 +159,7 @@
+ CXXFLAGS="$cflags" \
+ LDFLAGS="$ldflags" \
+ ../../gdb-$GDB_VER/configure \
+- --disable-nls --prefix=$prefix --target=$target --disable-werror \
++ --disable-nls --prefix=$prefix --target=$target --disable-werror --with-guile=no \
+ $CROSS_PARAMS \
+ || { echo "Error configuring gdb"; exit 1; }
+ touch configured-gdb
diff --git a/devkitarm-use-in-tree-isl.patch b/devkitarm-use-in-tree-isl.patch
deleted file mode 100644
index f9e306842039..000000000000
--- a/devkitarm-use-in-tree-isl.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -Naur buildscripts.old/build-devkit.sh buildscripts/build-devkit.sh
---- buildscripts.old/build-devkit.sh 2017-01-25 20:10:12.000000000 +0100
-+++ buildscripts/build-devkit.sh 2017-02-05 16:07:43.806595927 +0100
-@@ -232,6 +232,7 @@
-
- extract_and_patch binutils $BINUTILS_VER bz2
- extract_and_patch gcc $GCC_VER bz2
-+cp -ru "$SRCDIR/isl-0.16.1" gcc-$GCC_VER/isl
- extract_and_patch newlib $NEWLIB_VER gz
- extract_and_patch gdb $GDB_VER bz2
-
-diff -Naur buildscripts.old/dkppc/scripts/build-gcc.sh buildscripts/dkppc/scripts/build-gcc.sh
---- buildscripts.old/dkppc/scripts/build-gcc.sh 2017-01-25 17:52:19.000000000 +0100
-+++ buildscripts/dkppc/scripts/build-gcc.sh 2017-02-05 16:09:55.534185567 +0100
-@@ -91,6 +91,7 @@
- --disable-libstdcxx-verbose \
- --enable-cxx-flags='-ffunction-sections -fdata-sections' \
- --target=$target \
-+ --with-isl \
- --with-newlib \
- --with-headers=../../newlib-$NEWLIB_VER/newlib/libc/include \
- --prefix=$prefix\
diff --git a/fix-gcc-6.3.0-compilation-on-gcc-7.patch b/fix-gcc-6.3.0-compilation-on-gcc-7.patch
new file mode 100644
index 000000000000..be91072010cc
--- /dev/null
+++ b/fix-gcc-6.3.0-compilation-on-gcc-7.patch
@@ -0,0 +1,28 @@
+From 8db2cf6353c13f2a84cbe49b689654897906c499 Mon Sep 17 00:00:00 2001
+From: kyukhin <kyukhin@138bc75d-0d04-0410-961f-82ee72b054a4>
+Date: Sat, 3 Sep 2016 10:57:05 +0000
+Subject: [PATCH] gcc/ * ubsan.c (ubsan_use_new_style_p): Fix check for empty
+ string.
+
+git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@239971 138bc75d-0d04-0410-961f-82ee72b054a4
+
+Upstream-Status: Backport
+Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
+
+---
+ gcc/ubsan.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: gcc-6.3.0/gcc/ubsan.c
+===================================================================
+--- gcc-6.3.0.orig/gcc/ubsan.c
++++ gcc-6.3.0/gcc/ubsan.c
+@@ -1471,7 +1471,7 @@ ubsan_use_new_style_p (location_t loc)
+
+ expanded_location xloc = expand_location (loc);
+ if (xloc.file == NULL || strncmp (xloc.file, "\1", 2) == 0
+- || xloc.file == '\0' || xloc.file[0] == '\xff'
++ || xloc.file[0] == '\0' || xloc.file[0] == '\xff'
+ || xloc.file[1] == '\xff')
+ return false;
+
diff --git a/fix-gdb-7.12-compilation-on-gcc-7.patch b/fix-gdb-7.12-compilation-on-gcc-7.patch
new file mode 100644
index 000000000000..e21955d3fedd
--- /dev/null
+++ b/fix-gdb-7.12-compilation-on-gcc-7.patch
@@ -0,0 +1,32 @@
+From 909de2c5cc91b815d671f7018da2a925fbd19aaf Mon Sep 17 00:00:00 2001
+From: Tom Tromey <tom@tromey.com>
+Date: Mon, 24 Oct 2016 12:06:39 +0100
+Subject: [PATCH] PR gdb/20653 - small cleanup in string_to_explicit_location
+
+This bug points out that string_to_explicit_location compares a char*
+against '\0'; whereas comparing against NULL is more normal.
+
+2016-10-24 Tom Tromey <tom@tromey.com>
+
+ PR breakpoints/20653:
+ * location.c (string_to_explicit_location): Use NULL, not '\0'.
+---
+ gdb/location.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gdb/location.c b/gdb/location.c
+index 65116c7..8dce21a 100644
+--- a/gdb/location.c
++++ b/gdb/location.c
+@@ -524,7 +524,7 @@ string_to_explicit_location (const char **argp,
+ character is an explicit location. "-p" is reserved, though,
+ for probe locations. */
+ if (argp == NULL
+- || *argp == '\0'
++ || *argp == NULL
+ || *argp[0] != '-'
+ || !isalpha ((*argp)[1])
+ || ((*argp)[0] == '-' && (*argp)[1] == 'p'))
+--
+2.9.3
+