summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Andersson2016-01-17 21:59:14 +0100
committerMaxim Andersson2016-01-17 21:59:14 +0100
commit62d4554e6ee8cfda2d99ce3a19fd968ca8dd836b (patch)
tree0c2da37b9d15b8eee991da704fc2e141d91c80ff
downloadaur-62d4554e6ee8cfda2d99ce3a19fd968ca8dd836b.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af4511ce9b60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Jan 17 20:57:21 UTC 2016
+pkgbase = devpkgcheck
+ pkgdesc = Tool that builds and tests pkgbuilds with vcs sources from the AUR
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://gitlab.com/silentboatman/devpkgcheck
+ arch = any
+ license = GPL3
+ depends = namcap
+ backup = etc/devpkgcheck.conf
+ source = https://gitlab.com/silentboatman/devpkgcheck/repository/archive.tar.gz?ref=1.0
+ sha256sums = b7a04dd68de6385a6361dc40642dbd36fafbf8003a9df6cefe297cef24d88469
+
+pkgname = devpkgcheck
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00d104ecf641
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Maxim Andersson <thesilentboatman@gmail.com>
+
+pkgname=devpkgcheck
+pkgver=1.0
+pkgrel=1
+pkgdesc="Tool that builds and tests pkgbuilds with vcs sources from the AUR"
+arch=('any')
+url="https://gitlab.com/silentboatman/devpkgcheck"
+license=('GPL3')
+depends=('namcap')
+backup=('etc/devpkgcheck.conf')
+source=("https://gitlab.com/silentboatman/${pkgname}/repository/archive.tar.gz?ref=${pkgver}")
+sha256sums=('b7a04dd68de6385a6361dc40642dbd36fafbf8003a9df6cefe297cef24d88469')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"*
+
+ install -D "${pkgname}" -t "${pkgdir}/usr/bin"
+ install -D "${pkgname}.conf" -t "${pkgdir}/etc"
+}
+
+# vim:set ts=2 sw=2 et: