summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2016-11-12 10:48:07 +0100
committerGiovanni Santini2016-11-12 10:48:07 +0100
commit77a7213cb01a9743311e5d4363047af9b21d2805 (patch)
treeb1a5a24c9d84db4ee93e19daa241a200a4d9d57f
parenta4389017e51fd8f5a4944ce9aac6974827da01a6 (diff)
downloadaur-77a7213cb01a9743311e5d4363047af9b21d2805.tar.gz
upgpkg: devscripts 2.16.8-1
Switching to git for building the package
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81a36918ea72..eb6a226788f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Fri Sep 16 13:51:36 UTC 2016
+# Sat Nov 12 09:48:07 UTC 2016
pkgbase = devscripts
pkgdesc = Scripts to make the life of a Debian Package maintainer easier
- pkgver = 2.16.7
+ pkgver = 2.16.8
pkgrel = 1
url = http://packages.qa.debian.org/d/devscripts.html
install = devscripts.install
arch = any
license = GPL2
+ makedepends = git
makedepends = po4a
makedepends = perl-timedate
makedepends = perl-libwww
@@ -26,9 +27,9 @@ pkgbase = devscripts
depends = perl-timedate
optdepends = sensible-utils: for sensible alternative selection
options = !makeflags
- source = http://ftp.debian.org/debian/pool/main/d/devscripts/devscripts_2.16.7.tar.xz
+ source = devscripts-2.16.8::git+https://anonscm.debian.org/git/collab-maint/devscripts.git
source = fixes.patch
- md5sums = ba7491d3e9973d7440c49aefed937fbc
+ md5sums = SKIP
md5sums = 110857b0eb4a9dbf57a8b562d992ab33
pkgname = devscripts
diff --git a/PKGBUILD b/PKGBUILD
index 5ebc66131c52..e254f7d96f53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: JD Horelick <jdhore1@gmail.com>
pkgname=devscripts
-pkgver=2.16.7
+pkgver=2.16.8
pkgrel=1
pkgdesc="Scripts to make the life of a Debian Package maintainer easier"
arch=('any')
@@ -13,23 +13,27 @@ url="http://packages.qa.debian.org/d/devscripts.html"
license=('GPL2')
depends=('dpkg' 'wget' 'sed' 'perl' 'debianutils' 'debhelper' 'perl-timedate')
optdepends=('sensible-utils: for sensible alternative selection')
-makedepends=('po4a' 'perl-timedate' 'perl-libwww' 'docbook-xsl' 'perl-file-desktopentry' 'perl-file-basedir' 'perl-parse-debcontrol' 'python-setuptools' 'bash-completion')
+makedepends=('git' 'po4a' 'perl-timedate' 'perl-libwww' 'docbook-xsl' 'perl-file-desktopentry' 'perl-file-basedir' 'perl-parse-debcontrol' 'python-setuptools' 'bash-completion')
options=('!makeflags')
-source=(http://ftp.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_${pkgver}.tar.xz fixes.patch)
+source=(
+ #http://ftp.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_${pkgver}.tar.xz
+ ${pkgname}-${pkgver}::git+https://anonscm.debian.org/git/collab-maint/devscripts.git
+ fixes.patch
+)
install='devscripts.install'
-md5sums=('ba7491d3e9973d7440c49aefed937fbc'
+md5sums=('SKIP'
'110857b0eb4a9dbf57a8b562d992ab33')
build() {
- cd $srcdir/$pkgname-$pkgver
- patch -p0 -i ../fixes.patch
+ cd "$pkgname-$pkgver"
+ patch -p0 -i "$srcdir/fixes.patch"
make
}
package() {
- cd $srcdir/$pkgname-$pkgver
- make DESTDIR=$pkgdir install
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
# bts completion is present already in the official package
- rm $pkgdir/usr/share/bash-completion/completions/bts
+ rm "$pkgdir/usr/share/bash-completion/completions/bts"
}