summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2017-07-24 16:26:39 +0200
committerGiovanni Santini2017-07-24 16:26:39 +0200
commitad9dadb818b13429d7470526a18dc3fa4698f346 (patch)
treecac6b32ce610caf5cceaa9daee09388b58aece96
parenta47152bab3adbef5b3b21417f0374930eb34ccf5 (diff)
downloadaur-ad9dadb818b13429d7470526a18dc3fa4698f346.tar.gz
upgpkg: devscripts 2.17.9-1
- Version update. - Rework patch to fix build issues.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
-rw-r--r--fixes.patch14
3 files changed, 22 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ddea561f1806..4ecfd1a1ece2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri May 26 10:00:21 UTC 2017
+# Mon Jul 24 14:26:39 UTC 2017
pkgbase = devscripts
pkgdesc = Scripts to make the life of a Debian Package maintainer easier
- pkgver = 2.17.5
- pkgrel = 3
+ pkgver = 2.17.9
+ pkgrel = 1
url = http://packages.qa.debian.org/d/devscripts.html
arch = i686
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = devscripts
makedepends = bash-completion
makedepends = git
makedepends = perl-file-desktopentry
+ makedepends = perl-file-homedir
makedepends = perl-file-basedir
makedepends = perl-git-wrapper
makedepends = perl-libwww
@@ -29,10 +30,10 @@ pkgbase = devscripts
depends = perl-timedate
optdepends = sensible-utils: for sensible alternative selection
options = !makeflags
- source = devscripts::git+https://anonscm.debian.org/git/collab-maint/devscripts.git#tag=v2.17.5
+ source = devscripts::git+https://anonscm.debian.org/git/collab-maint/devscripts.git#tag=v2.17.9
source = fixes.patch
sha256sums = SKIP
- sha256sums = 9d038e5425848734874a03e2bdc0c8b86b1f42e9626f37dd916c1b7d73ad9141
+ sha256sums = e5fef21e1d8aee3128c6499078bc2f38e8f80189b30882df817637388f1e7717
pkgname = devscripts
diff --git a/PKGBUILD b/PKGBUILD
index 291f2a99cfaa..8bb3ceeda2d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: JD Horelick <jdhore1@gmail.com>
pkgname=devscripts
-pkgver=2.17.5
-pkgrel=3
+pkgver=2.17.9
+pkgrel=1
pkgdesc="Scripts to make the life of a Debian Package maintainer easier"
arch=('i686' 'x86_64')
url="http://packages.qa.debian.org/d/devscripts.html"
@@ -18,6 +18,7 @@ makedepends=(
'bash-completion'
'git'
'perl-file-desktopentry'
+ 'perl-file-homedir'
'perl-file-basedir'
'perl-git-wrapper'
'perl-libwww'
@@ -34,11 +35,15 @@ source=(
fixes.patch
)
sha256sums=('SKIP'
- '9d038e5425848734874a03e2bdc0c8b86b1f42e9626f37dd916c1b7d73ad9141')
+ 'e5fef21e1d8aee3128c6499078bc2f38e8f80189b30882df817637388f1e7717')
-build() {
+prepare(){
cd "$pkgname"
patch -p1 -i "$srcdir/fixes.patch"
+}
+
+build() {
+ cd "$pkgname"
make
}
diff --git a/fixes.patch b/fixes.patch
index 8bea0ec89345..64c554ea1835 100644
--- a/fixes.patch
+++ b/fixes.patch
@@ -1,5 +1,5 @@
diff --git a/po4a/Makefile b/po4a/Makefile
-index f19b24df..0c0dcd35 100644
+index f19b24df..6a43f037 100644
--- a/po4a/Makefile
+++ b/po4a/Makefile
@@ -28,7 +28,7 @@ de/%.de.1: de/%.de.pod translate
@@ -7,7 +7,7 @@ index f19b24df..0c0dcd35 100644
de/%.de.1: de/%.de.dbk translate
xsltproc --nonet -o $@ \
- /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/docbook.xsl $<
-+ /usr/share/xml/docbook/xsl-stylesheets-1.79.1/manpages/docbook.xsl $<
++ /usr/share/xml/docbook/xsl-stylesheets-1.79.2/manpages/docbook.xsl $<
# xsltproc writes out to foo.1 even if you tell it to do otherwise, so we have
# to rename the file after it's generated
mv de/$*.1 $@
@@ -16,24 +16,24 @@ index f19b24df..0c0dcd35 100644
fr/%.fr.1: fr/%.fr.dbk translate
xsltproc --nonet -o $@ \
- /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/docbook.xsl $<
-+ /usr/share/xml/docbook/xsl-stylesheets-1.79.1/manpages/docbook.xsl $<
++ /usr/share/xml/docbook/xsl-stylesheets-1.79.2/manpages/docbook.xsl $<
# xsltproc writes out to foo.1 even if you tell it to do otherwise, so we have
# to rename the file after it's generated
mv fr/$*.1 $@
diff --git a/scripts/Makefile b/scripts/Makefile
-index 931143a5..4696472c 100644
+index ece5455a..78bdb942 100644
--- a/scripts/Makefile
+++ b/scripts/Makefile
-@@ -63,7 +63,7 @@ endif
+@@ -64,7 +64,7 @@ endif
pod2man --utf8 --center=" " --release="Debian Utilities" $< > $@
%.1: %.dbk
xsltproc --nonet -o $@ \
- /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/docbook.xsl $<
-+ /usr/share/xml/docbook/xsl-stylesheets-1.79.1/manpages/docbook.xsl $<
++ /usr/share/xml/docbook/xsl-stylesheets-1.79.2/manpages/docbook.xsl $<
# There is a slight chance this gets called twice, once here from here and once
# from ../po4a/Makefile. Treat files with care.
-@@ -92,7 +92,7 @@ test:
+@@ -93,7 +93,7 @@ test:
$(foreach python,$(shell py3versions -r ../debian/control),$(python) setup.py test$(\n))
install: all