summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorprofessorkaos642016-09-15 13:57:41 -0400
committerprofessorkaos642016-09-15 13:57:41 -0400
commit0d7b0f2d396a17946192144d7ad0eab66cc81976 (patch)
tree1df4977c0ac81e6d2094aacc797afd95126a8c1f
downloadaur-0d7b0f2d396a17946192144d7ad0eab66cc81976.tar.gz
initial build
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD53
-rw-r--r--devscripts-git.install13
-rw-r--r--fixes.patch40
4 files changed, 141 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73b7e59d32c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = devscripts-git
+ pkgdesc = Scripts to make the life of a Debian Package maintainer easier (git-latest)
+ pkgver = v2.16.7
+ pkgrel = 1
+ url = https://anonscm.debian.org/git/collab-maint/devscripts.git
+ install = devscripts-git.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = po4a
+ makedepends = perl-timedate
+ makedepends = perl-libwww
+ makedepends = docbook-xsl
+ makedepends = perl-file-desktopentry
+ makedepends = perl-file-basedir
+ makedepends = perl-parse-debcontrol
+ makedepends = python-setuptools
+ depends = dpkg
+ depends = wget
+ depends = sed
+ depends = perl
+ depends = debianutils
+ depends = debhelper
+ depends = perl-timedate
+ optdepends = sensible-utils: for sensible alternative selection
+ provides = devscripts
+ conflicts = devscripts
+ options = !makeflags
+ source = git+https://anonscm.debian.org/git/collab-maint/devscripts.git
+ source = fixes.patch
+ md5sums = SKIP
+ md5sums = 110857b0eb4a9dbf57a8b562d992ab33
+
+pkgname = devscripts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da93607c124e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Michael DeGuzis
+# <mdeguzis@gmail.com> Git package
+# to stay up to date always If
+# there is not update to the AUR
+# package, remember to pass --devel
+# to your AUR helper (common flag).
+
+pkgname=devscripts-git
+_gitname=devscripts pkgver=v2.16.7
+pkgrel=1 pkgdesc="Scripts to make the life of a Debian Package maintainer easier (git-latest)"
+arch=('any')
+url="https://anonscm.debian.org/git/collab-maint/devscripts.git"
+license=('GPL2')
+depends=('dpkg' 'wget' 'sed' 'perl' 'debianutils'
+ 'debhelper' 'perl-timedate')
+optdepends=('sensible-utils: for sensible alternative selection')
+makedepends=('git' 'po4a' 'perl-timedate' 'perl-libwww' 'docbook-xsl'
+ 'perl-file-desktopentry' 'perl-file-basedir'
+ 'perl-parse-debcontrol' 'python-setuptools')
+conflicts=('devscripts')
+provides=('devscripts')
+options=('!makeflags')
+source=('git+https://anonscm.debian.org/git/collab-maint/devscripts.git'
+ 'fixes.patch')
+install='devscripts-git.install'
+md5sums=('SKIP'
+ '110857b0eb4a9dbf57a8b562d992ab33')
+
+pkgver() {
+ cd "$_gitname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+
+}
+
+build() {
+
+ cd $srcdir/$_gitname
+ patch -p0 -i ../fixes.patch
+ make
+
+}
+
+package() {
+
+ mkdir -p $pkgdir/etc/bash_completion.d
+ mkdir -p $pkgdir/usr/bin
+ mkdir -p $pkgdir/usr/lib/devscripts
+ mkdir -p $pkgdir/usr/share/devscripts
+
+ cd $srcdir/$_gitname
+ make DESTDIR=$pkgdir install
+
+}
diff --git a/devscripts-git.install b/devscripts-git.install
new file mode 100644
index 000000000000..cca372ce09f2
--- /dev/null
+++ b/devscripts-git.install
@@ -0,0 +1,13 @@
+post_install() {
+ ln -s /usr/bin/debchange /usr/bin/dch
+}
+
+
+post_remove() {
+ rm /usr/bin/dch
+}
+
+op=$1
+shift
+
+$op $*
diff --git a/fixes.patch b/fixes.patch
new file mode 100644
index 000000000000..a34f63a13cea
--- /dev/null
+++ b/fixes.patch
@@ -0,0 +1,40 @@
+--- po4a/Makefile 2013-09-17 11:58:14.177059023 +0100
++++ po4a/Makefile 2013-09-17 11:57:31.943725986 +0100
+@@ -25,7 +25,7 @@
+ pod2man --utf8 --center=" " --release="Debian-Hilfswerkzeuge" $< > $@
+ de/%.de.1: de/%.de.dbk translate
+ xsltproc --nonet -o $@ \
+- /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/docbook.xsl $<
++ /usr/share/xml/docbook/xsl-stylesheets-1.79.1/manpages/docbook.xsl $<
+ # xsltproc writes out to foo.1 even if you tell it to do otherwise, so we have
+ # to rename the file after it's generated
+ mv de/$*.1 $@
+@@ -35,7 +35,7 @@
+ pod2man --utf8 --center=" " --release="Utilitaires Debian" $< > $@
+ fr/%.fr.1: fr/%.fr.dbk translate
+ xsltproc --nonet -o $@ \
+- /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/docbook.xsl $<
++ /usr/share/xml/docbook/xsl-stylesheets-1.79.1/manpages/docbook.xsl $<
+ # xsltproc writes out to foo.1 even if you tell it to do otherwise, so we have
+ # to rename the file after it's generated
+ mv fr/$*.1 $@
+--- scripts/Makefile 2011-02-09 08:39:18.000000000 +0100
++++ scripts/Makefile 2011-02-13 17:50:50.393333338 +0100
+@@ -61,7 +61,7 @@
+ pod2man --utf8 --center=" " --release="Debian Utilities" $< > $@
+ %.1: %.dbk
+ xsltproc --nonet -o $@ \
+- /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/docbook.xsl $<
++ /usr/share/xml/docbook/xsl-stylesheets-1.79.1/manpages/docbook.xsl $<
+
+ # There is a slight chance this gets called twice, once here from here and once
+ # from ../po4a/Makefile. Treat files with care.
+@@ -89,7 +89,7 @@
+ $(foreach python,$(shell py3versions -r ../debian/control),$(python) setup.py test$(\n))
+
+ install: all
+- python3 setup.py install --root="$(DESTDIR)" --no-compile --install-layout=deb
++ python3 setup.py install --root="$(DESTDIR)" --no-compile
+ cp $(SCRIPTS) $(DESTDIR)$(BINDIR)
+ ln -sf edit-patch $(DESTDIR)$(BINDIR)/add-patch
+ install -d $(DESTDIR)$(COMPL_DIR)