summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXeonacid2022-03-09 10:29:45 +0800
committerXeonacid2022-03-09 10:29:45 +0800
commit27a9a389029fd1eb5657a96be1381ae7597ded57 (patch)
tree60c823b5bf9c0fd3055bc602fb874defd3e889c7
parentc1edca2137a54eb02ba0f20ce70fd6f59f77aee5 (diff)
downloadaur-27a9a389029fd1eb5657a96be1381ae7597ded57.tar.gz
Sync with devtools 20220207-2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--makepkg-riscv64.conf13
3 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 364917e8deae..f238e07324cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = devtools-riscv64
pkgdesc = Tools for Arch Linux RISC-V package maintainers
- pkgver = 1.0.0
- pkgrel = 4
+ pkgver = 1.0.1
+ pkgrel = 1
url = https://github.com/felixonmars/archriscv-packages
arch = x86_64
arch = riscv64
@@ -9,7 +9,7 @@ pkgbase = devtools-riscv64
depends = devtools
source = makepkg-riscv64.conf
source = pacman-extra-riscv64.conf
- sha256sums = d0eda35a669f0015c6f6bacf146145c821dffba42de663901da08d2c35a4c148
+ sha256sums = c8842d83460d44b873ff56c9ee0c982963ff76e5ed13897e5d7b8d7f0ea7c206
sha256sums = fc933f164d21774e7a1435d9fccf87cb05f7b601e89a2ba54b899b2ce1e809df
depends_x86_64 = qemu-user-static
depends_x86_64 = binfmt-qemu-static
diff --git a/PKGBUILD b/PKGBUILD
index c97d34768f80..94a020f8592e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Xeonacid <h.dwwwwww at gmail dot com>
pkgname=devtools-riscv64
-pkgver=1.0.0
-pkgrel=4
+pkgver=1.0.1
+pkgrel=1
pkgdesc='Tools for Arch Linux RISC-V package maintainers'
arch=('x86_64' 'riscv64')
license=('GPL')
@@ -11,7 +11,7 @@ depends=('devtools')
depends_x86_64=('qemu-user-static' 'binfmt-qemu-static')
source=(makepkg-riscv64.conf
pacman-extra-riscv64.conf)
-sha256sums=('d0eda35a669f0015c6f6bacf146145c821dffba42de663901da08d2c35a4c148'
+sha256sums=('c8842d83460d44b873ff56c9ee0c982963ff76e5ed13897e5d7b8d7f0ea7c206'
'fc933f164d21774e7a1435d9fccf87cb05f7b601e89a2ba54b899b2ce1e809df')
package() {
diff --git a/makepkg-riscv64.conf b/makepkg-riscv64.conf
index 3c8954e778a1..c2b86af7bcb1 100644
--- a/makepkg-riscv64.conf
+++ b/makepkg-riscv64.conf
@@ -9,10 +9,10 @@
#
#-- The download utilities that makepkg should use to acquire sources
# Format: 'protocol::agent'
-DLAGENTS=('file::/usr/bin/curl -gqC - -o %o %u'
- 'ftp::/usr/bin/curl -gqfC - --ftp-pasv --retry 3 --retry-delay 3 -o %o %u'
- 'http::/usr/bin/curl -gqb "" -fLC - --retry 3 --retry-delay 3 -o %o %u'
- 'https::/usr/bin/curl -gqb "" -fLC - --retry 3 --retry-delay 3 -o %o %u'
+DLAGENTS=('file::/usr/bin/curl -qgC - -o %o %u'
+ 'ftp::/usr/bin/curl -qgfC - --ftp-pasv --retry 3 --retry-delay 3 -o %o %u'
+ 'http::/usr/bin/curl -qgb "" -fLC - --retry 3 --retry-delay 3 -o %o %u'
+ 'https::/usr/bin/curl -qgb "" -fLC - --retry 3 --retry-delay 3 -o %o %u'
'rsync::/usr/bin/rsync --no-motd -z %u %o'
'scp::/usr/bin/scp -C %u %o')
@@ -43,12 +43,13 @@ CFLAGS="-march=rv64gc -mabi=lp64d -O2 -pipe -fexceptions \
-fstack-clash-protection"
CXXFLAGS="$CFLAGS -Wp,-D_GLIBCXX_ASSERTIONS"
LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now"
+LTOFLAGS="-flto=auto"
#RUSTFLAGS="-C opt-level=2"
#-- Make Flags: change this for DistCC/SMP systems
#MAKEFLAGS="-j2"
#-- Debugging flags
-DEBUG_CFLAGS="-g -fvar-tracking-assignments"
-DEBUG_CXXFLAGS="-g -fvar-tracking-assignments"
+DEBUG_CFLAGS="-g"
+DEBUG_CXXFLAGS="$DEBUG_CFLAGS"
#DEBUG_RUSTFLAGS="-C debuginfo=2"
#########################################################################