summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXeonacid2023-02-24 14:54:07 +0800
committerXeonacid2023-02-24 14:54:07 +0800
commit70c113fe0db12eb5a30c6e3c97c4bd29ac049395 (patch)
treedb1f96f5530dc8689498c082561223b627556a8d
parent40b4888f5028686ee3a46989adaeb4c0cb003633 (diff)
downloadaur-70c113fe0db12eb5a30c6e3c97c4bd29ac049395.tar.gz
devtools-riscv64: Revert "use binfmt conf from Arch"
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--z-archriscv-qemu-riscv64.conf1
3 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86376eca9480..55428942155a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = devtools-riscv64
pkgdesc = Tools for Arch Linux RISC-V package maintainers
- pkgver = 1.4.0
+ pkgver = 1.5.0
pkgrel = 1
url = https://github.com/felixonmars/archriscv-packages
arch = x86_64
@@ -13,7 +13,8 @@ pkgbase = devtools-riscv64
sha256sums = 2abae300509c2fbae0246f195fb7ffa17c4ad240052f1e60b0bc504de6149685
sha256sums = 1c79f2817f81e18060a37b237bd1ec619af5447d0884d525aa87aa2165df16b2
sha256sums = 3721d7ca08eae58ef2a9de6d8f9ccf2fae1f330949bbf5f566db4c2efbd06105
+ source_x86_64 = z-archriscv-qemu-riscv64.conf
depends_x86_64 = qemu-user-static
- depends_x86_64 = qemu-user-static-binfmt
+ sha256sums_x86_64 = c59273c423e815e4c27e8486632d80a768adddd172119035d48f7c2fac98a87a
pkgname = devtools-riscv64
diff --git a/PKGBUILD b/PKGBUILD
index f0e113427f44..23cb7dde2476 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
# Maintainer: Xeonacid <h.dwwwwww at gmail dot com>
pkgname=devtools-riscv64
-pkgver=1.4.0
+pkgver=1.5.0
pkgrel=1
pkgdesc='Tools for Arch Linux RISC-V package maintainers'
arch=('x86_64' 'riscv64')
license=('GPL')
url='https://github.com/felixonmars/archriscv-packages'
depends=('devtools')
-depends_x86_64=('qemu-user-static' 'qemu-user-static-binfmt')
+depends_x86_64=('qemu-user-static')
source=(makepkg-riscv64.patch
pacman-extra-riscv64.patch
sogrep-riscv64)
+source_x86_64=('z-archriscv-qemu-riscv64.conf')
sha256sums=('2abae300509c2fbae0246f195fb7ffa17c4ad240052f1e60b0bc504de6149685'
'1c79f2817f81e18060a37b237bd1ec619af5447d0884d525aa87aa2165df16b2'
'3721d7ca08eae58ef2a9de6d8f9ccf2fae1f330949bbf5f566db4c2efbd06105')
+sha256sums_x86_64=('c59273c423e815e4c27e8486632d80a768adddd172119035d48f7c2fac98a87a')
package() {
install -Dm755 sogrep-riscv64 -t "$pkgdir"/usr/bin/
@@ -27,6 +29,9 @@ package() {
if [[ ! "$CARCH" =~ riscv ]]; then
install -dm755 "$pkgdir"/usr/share/devtools/setarch-aliases.d
echo "$CARCH" > "$pkgdir"/usr/share/devtools/setarch-aliases.d/riscv64
+
+ # qemu-user-static-binfmt, but with C flag
+ install -Dm644 z-archriscv-qemu-riscv64.conf -t "$pkgdir"/usr/lib/binfmt.d/
fi
}
diff --git a/z-archriscv-qemu-riscv64.conf b/z-archriscv-qemu-riscv64.conf
new file mode 100644
index 000000000000..be4ec39ccad2
--- /dev/null
+++ b/z-archriscv-qemu-riscv64.conf
@@ -0,0 +1 @@
+:qemu-riscv64:M::\x7f\x45\x4c\x46\x02\x01\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x02\x00\xf3\x00:\xff\xff\xff\xff\xff\xff\xff\x00\xff\xff\xff\xff\xff\xff\xff\xff\xfe\xff\xff\xff:/usr/bin/qemu-riscv64-static:PCF