summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCraig Barnes2016-11-27 23:45:50 +0000
committerCraig Barnes2016-11-27 23:45:50 +0000
commit9bed09e511b4009b4a174b7dc0313ada1828e518 (patch)
treec7ea37c99da74fffe3bc543983ac95dece7b2e1e
downloadaur-9bed09e511b4009b4a174b7dc0313ada1828e518.tar.gz
Initial PKGBUILD for dex editor v1.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6980368376b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = dex-editor
+ pkgdesc = A small and easy to use text editor
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/tihirvon/dex
+ arch = i686
+ arch = x86_64
+ arch = armv7l
+ license = GPL2
+ depends = glibc
+ depends = ncurses
+ conflicts = dex
+ source = https://github.com/tihirvon/dex/archive/v1.0/dex-1.0.tar.gz
+ md5sums = 2cccdd7454dc58a6d05273f3fcf73518
+ sha1sums = f7709f465738a314804bc199701ccad1fcf7792a
+
+pkgname = dex-editor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aefbc83aa9e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname='dex-editor'
+pkgver='1.0'
+pkgrel='1'
+pkgdesc='A small and easy to use text editor'
+url='https://github.com/tihirvon/dex'
+arch=('i686' 'x86_64' 'armv7l')
+license=('GPL2')
+depends=('glibc' 'ncurses')
+conflicts=('dex')
+source=('https://github.com/tihirvon/dex/archive/v1.0/dex-1.0.tar.gz')
+md5sums=('2cccdd7454dc58a6d05273f3fcf73518')
+sha1sums=('f7709f465738a314804bc199701ccad1fcf7792a')
+
+build() {
+ cd "dex-$pkgver"
+ make prefix=/usr DESTDIR="$pkgdir"
+}
+
+package() {
+ cd "dex-$pkgver"
+ make prefix=/usr DESTDIR="$pkgdir" install
+}