summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbug2021-07-13 22:50:04 +0300
committerbug2021-07-13 22:55:12 +0300
commitef31000f0e8540d4950ceeb7abd9348aa1d34b36 (patch)
treec1da9471f2eed561dddecd7350e2c26037f3f475
parent12ec69f557b91674e9e9bf102734db504a5d9ac1 (diff)
downloadaur-ef31000f0e8540d4950ceeb7abd9348aa1d34b36.tar.gz
Initial commit
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD33
2 files changed, 33 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54bab3f8a142..7979bdd95e06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = dexed-ide
pkgdesc = IDE for the D programming language, its compilers, tools and libraries
- pkgver = 3.9.4
+ pkgver = 3.9.11
pkgrel = 1
url = https://gitlab.com/basile.b/dexed
arch = x86_64
license = Boost
+ makedepends = lazarus
+ makedepends = git
depends = dcd
depends = dscanner
- source = https://gitlab.com/basile.b/dexed/-/jobs/572632492/artifacts/raw/setup/output/dexed.3.9.4.linux64.zip
- md5sums = d9646cff816913f3c625d3c6c890b78d
+ depends = vte-legacy
+ conflicts = dexed-ide-bin
+ source = git+https://gitlab.com/basile.b/dexed.git#tag=v3.9.11
+ md5sums = SKIP
pkgname = dexed-ide
-
diff --git a/PKGBUILD b/PKGBUILD
index 9e7be9e4df13..92d350bdfb48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,36 @@
-# Maintainer: Sebastiaan de Schaetzen <sebastiaan.de.schaetzen@gmail.com>
+# Contributor: Bug <bug2000@gmail.com>
+# Maintainer: Bug <bug2000@gmail.com>
pkgname=dexed-ide
-pkgver=3.9.4
+_pkgname=dexed
+pkgver=3.9.11
pkgrel=1
pkgdesc="IDE for the D programming language, its compilers, tools and libraries"
arch=(x86_64)
url="https://gitlab.com/basile.b/dexed"
license=('Boost')
-depends=(dcd dscanner)
+depends=(dcd dscanner vte-legacy)
+makedepends=(lazarus git)
+conflicts=(dexed-ide-bin)
checkdepends=()
-source=(https://gitlab.com/basile.b/dexed/-/jobs/572632492/artifacts/raw/setup/output/dexed.$pkgver.linux64.zip)
-md5sums=('d9646cff816913f3c625d3c6c890b78d')
+#source=("https://gitlab.com/basile.b/$_pkgname/-/archive/v$pkgver/$_pkgname-v$pkgver.tar.gz")
+source=("git+https://gitlab.com/basile.b/$_pkgname.git#tag=v$pkgver")
+md5sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ git submodule update --init
+}
+
+build() {
+ cd "$_pkgname"
+ cd lazproj
+ lazbuild -B dexeddesigncontrols.lpk
+ lazbuild -B dexed.lpi
+}
package() {
- mkdir -p $pkgdir/usr/bin
- cp $srcdir/dexed-x86_64/{dexed,dastworx} $pkgdir/usr/bin
+ cd "$_pkgname"
+ install -Dm755 "bin/dexed" "${pkgdir}/usr/bin/dexed"
+ install -Dm644 "bin/libdexed-d.so" "${pkgdir}/usr/lib/libdexed-d.so"
}
+