summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:10:25 +0200
committerChristopher Reimer2015-06-08 11:10:25 +0200
commite85ae81ada031dbd14e1d4f091a59cc80943a23c (patch)
treee44a0daa1564319e7db550451ed2eb67e12411cf
downloadaur-e85ae81ada031dbd14e1d4f091a59cc80943a23c.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
-rw-r--r--.SRCINFO44
-rw-r--r--45-df10ch.rules1
-rw-r--r--50-dfatmo.conf2
-rw-r--r--PKGBUILD70
4 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0daa3557608d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+pkgbase = dfatmo
+ pkgver = 0.4.0
+ pkgrel = 12
+ epoch = 1
+ url = https://github.com/durchflieger/dfatmo
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ makedepends = libusbx
+ makedepends = python2
+ makedepends = vdr-api=2.2.0
+ makedepends = zip
+ source = https://github.com/durchflieger/dfatmo/archive/v0.4.0.tar.gz
+ source = 45-df10ch.rules
+ source = 50-dfatmo.conf
+ md5sums = c10affe8304d494fee575d95ff791dca
+ md5sums = c5e0bf17e88febc7e86c7e435f5eea5f
+ md5sums = f8f2376c860c78f522e40b1afd02d38c
+
+pkgname = dfatmo
+ pkgdesc = Analyzes the video picture and generates output data for so called 'Atmolight' controllers
+ depends = libusbx
+ depends = python2
+ conflicts = dfatmo-driver
+ replaces = dfatmo-driver
+
+pkgname = vdr-dfatmo
+ pkgdesc = VDR plugin to drive a colored back lighting for TVs
+ depends = gcc-libs
+ depends = dfatmo
+ depends = vdr-api=2.2.0
+ backup = etc/vdr/conf.avail/50-.conf
+
+pkgname = kodi-addon-dfatmo
+ pkgdesc = VDR plugin to drive a colored back lighting for TVs
+ arch = any
+ depends = dfatmo
+ depends = kodi
+ conflicts = xbmc-addon-dfatmo
+ replaces = xbmc-addon-dfatmo
+
diff --git a/45-df10ch.rules b/45-df10ch.rules
new file mode 100644
index 000000000000..1a823333d755
--- /dev/null
+++ b/45-df10ch.rules
@@ -0,0 +1 @@
+ACTION=="add", SUBSYSTEM=="usb*", ATTR{idVendor}=="16c0", ATTR{idProduct}=="05dc", MODE="0666", GROUP="vdr"
diff --git a/50-dfatmo.conf b/50-dfatmo.conf
new file mode 100644
index 000000000000..d1d3716ab511
--- /dev/null
+++ b/50-dfatmo.conf
@@ -0,0 +1,2 @@
+[dfatmo]
+#--log=LOG_LEVEL
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e0006fc7874
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Ole Ernst <olebowle[at]gmx[dot]com>
+# Contributor: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgbase=dfatmo
+pkgname=('dfatmo' 'vdr-dfatmo' 'kodi-addon-dfatmo')
+pkgver=0.4.0
+_vdrapi=2.2.0
+pkgrel=12
+epoch=1
+url="https://github.com/durchflieger/${pkgbase}"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+makedepends=('libusbx' 'python2' "vdr-api=${_vdrapi}" 'zip')
+source=("https://github.com/durchflieger/${pkgbase}/archive/v${pkgver}.tar.gz"
+ '45-df10ch.rules'
+ "50-dfatmo.conf")
+md5sums=('c10affe8304d494fee575d95ff791dca'
+ 'c5e0bf17e88febc7e86c7e435f5eea5f'
+ 'f8f2376c860c78f522e40b1afd02d38c')
+prepare() {
+ cd "${srcdir}/DFAtmo-${pkgver}"
+ sed -i "s/python-config/python2-config/" Makefile
+ sed -i 's/static const char \*libusb/const char \*libusb/g' df10choutputdriver.c
+}
+
+build() {
+ cd "${srcdir}/DFAtmo-${pkgver}"
+
+ #Compile dfatmo
+ CFLAGS+=' -fPIC'
+ make DFATMOINSTDIR='/usr' ATMODRIVER=atmodriver.so
+
+ #Compile vdr plugin
+ make DFATMOINSTDIR='/usr' vdrplugin
+}
+
+package_dfatmo() {
+ pkgdesc="Analyzes the video picture and generates output data for so called 'Atmolight' controllers"
+ replaces=('dfatmo-driver')
+ conflicts=('dfatmo-driver')
+ depends=('libusbx' 'python2')
+
+ cd "${srcdir}/DFAtmo-${pkgver}"
+ make DFATMOINSTDIR="${pkgdir}/usr" ATMODRIVER=atmodriver.so dfatmoinstall
+}
+
+package_vdr-dfatmo() {
+ pkgdesc="VDR plugin to drive a colored back lighting for TVs"
+ depends=('gcc-libs' 'dfatmo' "vdr-api=${_vdrapi}")
+ _plugname=$(echo $pkgname | sed 's/vdr-//g')
+ backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+
+ cd "${srcdir}/DFAtmo-${pkgver}"
+ make VDRDESTDIR="${pkgdir}" vdrinstall
+ install -Dm644 "${srcdir}/45-df10ch.rules" "${pkgdir}/usr/lib/udev/rules.d/45-df10ch.rules"
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}
+
+package_kodi-addon-dfatmo() {
+ pkgdesc="VDR plugin to drive a colored back lighting for TVs"
+ arch=('any')
+ replaces=('xbmc-addon-dfatmo')
+ conflicts=('xbmc-addon-dfatmo')
+ depends=('dfatmo' 'kodi')
+
+ cd "${srcdir}/DFAtmo-${pkgver}"
+ make XBMCDESTDIR="$pkgdir/usr/share/kodi/addons/script.dfatmo" xbmcinstall
+}