summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZiusudra2022-09-30 21:48:42 -0600
committerZiusudra2022-09-30 21:48:42 -0600
commit682a48c37c7f47fa18329e92404bbc807462475d (patch)
tree6acbd75df3fbf8008f455f074550770d97ae2906
parenta04e254586548bfbe91e5986c52f8a6b44e3909e (diff)
downloadaur-682a48c37c7f47fa18329e92404bbc807462475d.tar.gz
updated launch scripts
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--dfhack-run.sh25
-rw-r--r--dfhack.sh8
4 files changed, 17 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d08664cd65e0..c0e0eda58e38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dfhack
pkgdesc = memory hacking library for Dwarf Fortress and a set of tools that use it
pkgver = 0.47.05
- pkgrel = 9
+ pkgrel = 10
url = https://dfhack.readthedocs.io/en/stable/
arch = x86_64
arch = i686
@@ -29,8 +29,8 @@ pkgbase = dfhack
source = dfhack-run.sh
source = Wno-restrict.patch
md5sums = SKIP
- md5sums = 81f5909c1a32391679f968e40f24d5ca
- md5sums = 3853c6f890d3541f710f2c4833a9e696
+ md5sums = 45ab3b65cb5b01beff9fecccff777f85
+ md5sums = 37421a6cf2ca420bed4420ea8e402d40
md5sums = 086fc32900f4c6589a06ac1c7acc6e98
pkgname = dfhack
diff --git a/PKGBUILD b/PKGBUILD
index 677c1a883dd1..6eacc28eb6dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=dfhack
pkgver=0.47.05
_pkgver=$pkgver-r7
-pkgrel=9
+pkgrel=10
pkgdesc="memory hacking library for Dwarf Fortress and a set of tools that use it"
arch=('x86_64' 'i686')
url="https://dfhack.readthedocs.io/en/stable/"
@@ -22,8 +22,8 @@ source=("$pkgname::git+https://github.com/DFHack/dfhack#tag=$_pkgver"
Wno-restrict.patch)
md5sums=('SKIP'
- '81f5909c1a32391679f968e40f24d5ca'
- '3853c6f890d3541f710f2c4833a9e696'
+ '45ab3b65cb5b01beff9fecccff777f85'
+ '37421a6cf2ca420bed4420ea8e402d40'
'086fc32900f4c6589a06ac1c7acc6e98')
prepare() {
diff --git a/dfhack-run.sh b/dfhack-run.sh
index 7355a7d58f42..a4e3e1f730b3 100644
--- a/dfhack-run.sh
+++ b/dfhack-run.sh
@@ -2,27 +2,18 @@
# check for dwarffortress user directory
if [[ ! -d ~/.dwarffortress ]] ; then
- mkdir -p ~/.dwarffortress/data
-
- ln -s /opt/dwarffortress/raw ~/.dwarffortress/raw
- ln -s /opt/dwarffortress/libs ~/.dwarffortress/libs
- cp -rn /opt/dwarffortress/data/init ~/.dwarffortress/data/init
-
- for link in announcement art dipscript help index initial_movies movies shader.fs shader.vs sound speech ; do
- cp -r /opt/dwarffortress/data/$link ~/.dwarffortress/data/$link
- done
+ echo "Error: dfhack-run passes commands to a running instance of\
+ DFHack, but ~/.dwarffortress/ does not exist and should have been\
+ created when dfhack was run" >&2
+ exit 1
fi
# check for dfhack user directory
if [[ ! -d ~/.dwarffortress/hack ]] ; then
- ln -s /opt/dwarffortress/hack ~/.dwarffortress/hack
- ln -s /opt/dwarffortress/stonesense ~/.dwarffortress/stonesense
- ln -s /opt/dwarffortress/dfhack ~/.dwarffortress/dfhack
- ln -s /opt/dwarffortress/dfhack-run ~/.dwarffortress/dfhack-run
- ln -s /opt/dwarffortress/dfhack.init-example ~/.dwarffortress/dfhack.init-example
- cp -r /opt/dwarffortress/dfhack-config ~/.dwarffortress/dfhack-config
-
- cp ~/.dwarffortress/dfhack.init{-example,}
+ echo "Error: dfhack-run passes commands to a running instance of\
+ DFHack, but ~/.dwarffortress/hack/ does not exist and should have been\
+ created when dfhack was run" >&2
+ exit 1
fi
# workaround for bug in Debian/Ubuntu SDL patch
diff --git a/dfhack.sh b/dfhack.sh
index 0acc659db555..b0da560d34fa 100644
--- a/dfhack.sh
+++ b/dfhack.sh
@@ -15,14 +15,12 @@ fi
# check for dfhack user directory
if [[ ! -d ~/.dwarffortress/hack ]] ; then
- ln -s /opt/dwarffortress/hack ~/.dwarffortress/hack
- ln -s /opt/dwarffortress/stonesense ~/.dwarffortress/stonesense
ln -s /opt/dwarffortress/dfhack ~/.dwarffortress/dfhack
ln -s /opt/dwarffortress/dfhack-run ~/.dwarffortress/dfhack-run
- ln -s /opt/dwarffortress/dfhack.init-example ~/.dwarffortress/dfhack.init-example
+ ln -s /opt/dwarffortress/blueprints ~/.dwarffortress/blueprints
+ ln -s /opt/dwarffortress/hack ~/.dwarffortress/hack
+ ln -s /opt/dwarffortress/stonesense ~/.dwarffortress/stonesense
cp -r /opt/dwarffortress/dfhack-config ~/.dwarffortress/dfhack-config
-
- cp ~/.dwarffortress/dfhack.init{-example,}
fi
# workaround for bug in Debian/Ubuntu SDL patch