summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Johansen2022-09-28 11:16:39 +0200
committerDan Johansen2022-09-28 11:16:39 +0200
commit5ecfd8b1e6761bcf8d38af2f78742537f1a7d1f6 (patch)
tree437fc5ce741fff678eacee6e8622d17d56dc2671
downloadaur-5ecfd8b1e6761bcf8d38af2f78742537f1a7d1f6.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c37e8212575e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dfl-gamma-effects
+ pkgdesc = A class to handle various display effects that can be performed using wlr-gamma-control protocol
+ pkgver = 0.1.0alpha1
+ pkgrel = 1
+ url = https://gitlab.com/desktop-frameworks/gamma-effects
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = meson
+ makedepends = ninja
+ depends = qt5-base
+ depends = dfl-wayqt
+ source = https://gitlab.com/desktop-frameworks/gamma-effects/-/archive/v0.1.0-alpha1/gamma-effects-v0.1.0-alpha1.tar.gz
+ md5sums = 0bd2b50e330f9b145911a38115fb9a27
+
+pkgname = dfl-gamma-effects
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cb30a9bf2e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Dan Johansen <strit@manjaro.org>
+
+## Build order:
+## dfl-wayqt -> dfl-gamma-effects
+
+_pkgname=gamma-effects
+pkgname=dfl-gamma-effects
+pkgver=0.1.0alpha1
+pkgrel=1
+pkgdesc="A class to handle various display effects that can be performed using wlr-gamma-control protocol"
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/desktop-frameworks/$_pkgname"
+license=('GPL3')
+depends=('qt5-base' 'dfl-wayqt')
+makedepends=('meson' 'ninja')
+source=("$url/-/archive/v${pkgver/alpha1/-alpha1}/${_pkgname}-v${pkgver/alpha1/-alpha1}.tar.gz")
+md5sums=('0bd2b50e330f9b145911a38115fb9a27')
+
+build() {
+ cd "${_pkgname}-v${pkgver/alpha1/-alpha1}"
+ meson .build --prefix=/usr --buildtype=release
+ ninja -C .build
+}
+
+package() {
+ cd "${_pkgname}-v${pkgver/alpha1/-alpha1}"
+ DESTDIR="${pkgdir}" ninja -C .build install
+}