diff options
author | Dan Johansen | 2022-10-25 21:17:41 +0200 |
---|---|---|
committer | Dan Johansen | 2022-10-25 21:17:41 +0200 |
commit | 1cba4ee5f317d46a46515c6d2447960dbeff4557 (patch) | |
tree | 020f014b05a088836c1f70c0e1e72617c1bfce14 | |
parent | 4189abe68694f5f24a984ba23ebba542b9efe682 (diff) | |
download | aur-1cba4ee5f317d46a46515c6d2447960dbeff4557.tar.gz |
updated to 0.1.1 and build both qt5 and qt6 based packages
-rw-r--r-- | .SRCINFO | 13 | ||||
-rw-r--r-- | PKGBUILD | 24 |
2 files changed, 27 insertions, 10 deletions
@@ -1,6 +1,6 @@ pkgbase = dfl-notification pkgdesc = Implementation of the XDG Desktop Notification Spec - pkgver = 0.1.0 + pkgver = 0.1.1 pkgrel = 1 url = https://gitlab.com/desktop-frameworks/notification arch = x86_64 @@ -8,8 +8,13 @@ pkgbase = dfl-notification license = GPL3 makedepends = meson makedepends = ninja - depends = qt5-base - source = https://gitlab.com/desktop-frameworks/notification/-/archive/v0.1.0/notification-v0.1.0.tar.gz - md5sums = 1693118dc894eb46fb44580bc84fc538 + makedepends = qt5-base + makedepends = qt6-base + source = https://gitlab.com/desktop-frameworks/notification/-/archive/v0.1.1/notification-v0.1.1.tar.gz + md5sums = 27992953af2047d8d6c6dd4a4b7bd970 pkgname = dfl-notification + depends = qt5-base + +pkgname = dfl-notification-qt6 + depends = qt6-base @@ -1,25 +1,37 @@ # Maintainer: Dan Johansen <strit@manjaro.org> _pkgname=notification -pkgname=dfl-notification -pkgver=0.1.0 +pkgbase=dfl-notification +pkgname=('dfl-notification' 'dfl-notification-qt6') +pkgver=0.1.1 pkgrel=1 pkgdesc="Implementation of the XDG Desktop Notification Spec" arch=('x86_64' 'aarch64') url="https://gitlab.com/desktop-frameworks/$_pkgname" license=('GPL3') -depends=('qt5-base') -makedepends=('meson' 'ninja') +makedepends=('meson' 'ninja' 'qt5-base' 'qt6-base') source=("$url/-/archive/v${pkgver}/${_pkgname}-v${pkgver}.tar.gz") -md5sums=('1693118dc894eb46fb44580bc84fc538') +md5sums=('27992953af2047d8d6c6dd4a4b7bd970') build() { cd "${_pkgname}-v${pkgver}" + echo "Building QT5 version..." meson .build --prefix=/usr --buildtype=release ninja -C .build + + echo "Building QT6 version..." + meson .build-qt6 --prefix=/usr -Duse_qt_version=qt6 --buildtype=release + ninja -C .build-qt6 } -package() { +package_dfl-notification() { + depends=('qt5-base') cd "${_pkgname}-v${pkgver}" DESTDIR="${pkgdir}" ninja -C .build install } + +package_dfl-notification-qt6() { + depends=('qt6-base') + cd "${_pkgname}-v${pkgver}" + DESTDIR="${pkgdir}" ninja -C .build-qt6 install +} |