summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Printzell2017-07-24 15:11:27 +0200
committerDan Printzell2017-07-24 15:11:27 +0200
commit30ff425510000ceec4bf84a69742f0adc5b9e66e (patch)
tree19df2df675594ade95bee9203ba3e7aaf945c402
parent35ca333cb5906d55b6fc3ec8fcd67f7439f3e078 (diff)
downloadaur-30ff425510000ceec4bf84a69742f0adc5b9e66e.tar.gz
Fixed pkgver and submodules
Signed-off-by: Dan Printzell <xwildn00bx@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0748a3aac987..306149a78ec0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Jul 24 01:17:02 UTC 2017
+# Mon Jul 24 13:09:44 UTC 2017
pkgbase = dfmt-git
pkgdesc = Dfmt is a formatter for D source code
- pkgver = r419.ea72aa5
+ pkgver = 0.5.0.r4.ea72aa5
pkgrel = 1
url = https://github.com/dlang-community/dfmt
arch = i686
@@ -15,6 +15,8 @@ pkgbase = dfmt-git
provides = dfmt
conflicts = dfmt
source = git+https://github.com/dlang-community/dfmt
+ source = git+https://github.com/Hackerpilot/libdparse
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = dfmt-git
diff --git a/PKGBUILD b/PKGBUILD
index a28335c0db58..ea10f39c37b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dan Printzell <arch@vild.io>
pkgname=('dfmt-git')
-pkgver=r419.ea72aa5
+pkgver=0.5.0.r4.ea72aa5
pkgrel=1
pkgdesc="Dfmt is a formatter for D source code "
arch=('i686' 'x86_64')
@@ -15,19 +15,24 @@ conflicts=('dfmt')
source=(
"git+https://github.com/dlang-community/dfmt"
+ "git+https://github.com/Hackerpilot/libdparse"
)
sha256sums=(
'SKIP'
+ 'SKIP'
)
pkgver() {
cd "$srcdir/dfmt"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
}
prepare() {
cd "$srcdir/dfmt"
- git submodule update --init --recursive
+
+ git submodule init
+ git config submodule.libdparse.url "$srcdir/libdparse"
+ git submodule update
}
build() {