summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Lüdecke2016-01-14 18:05:00 +0100
committerMoritz Lüdecke2016-01-14 18:05:00 +0100
commitb65362afb555f5f2a67133ac2c11ae420fbd97a2 (patch)
treeb487c638fadbb8b91429c20e79fb9c0a024bda19
parent448b3919929b485d5421a4d70a4bdf89ea8c2e06 (diff)
downloadaur-b65362afb555f5f2a67133ac2c11ae420fbd97a2.tar.gz
Fix installation conflicts
-rw-r--r--PKGBUILD2
-rwxr-xr-xdfp55
2 files changed, 1 insertions, 56 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8816b322a25b..b444b4330ef9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Moritz Luedecke <ritze@skweez.net>
pkgname=dfp
pkgver=20141004
-pkgrel=1
+pkgrel=2
pkgdesc="df with progress bar in pacman style"
url="https://github.com/ritze/dfp"
license="GPL"
diff --git a/dfp b/dfp
deleted file mode 100755
index 069751677cc3..000000000000
--- a/dfp
+++ /dev/null
@@ -1,55 +0,0 @@
-#!/bin/bash
-
-DF="/usr/bin/df"
-
-usage() {
- echo 'usage: dfp [-p PREFIX] DEVICE...'
- echo
- echo ' -p print given prefix at the begin of each line'
- echo ' -h display this help and exit'
- exit
-}
-
-while getopts ":hp:" optname; do
- case "$optname" in
- "p")
- prefix=$OPTARG
- ;;
- "h")
- usage
- ;;
- "?")
- echo "Unknown option $OPTARG"
- usage
- ;;
- ":")
- echo "No argument value for option $OPTARG"
- ;;
- *)
- echo "Unknown error while processing options"
- ;;
- esac
-done
-
-IFS=$"NUL"
-declare -a args=${@:$OPTIND}
-[[ ${args:0} ]] || args=$(df --output=target | tail --lines=+2 | tr "\n" $"NUL")
-
-for device in $args; do
- if ! [[ "$($DF $device)" ]]; then
- usage
- fi
-done
-
-for device in $args; do
- size="$($DF $device --output=size | tail --lines=+2)"
- avail="$($DF $device --output=avail | tail --lines=+2)"
- used="$((size - avail))"
-
- availh="$($DF -h $device --output=avail | tail --lines=+2)"
- sizeh="$($DF -h $device --output=size | tail --lines=+2)"
- misc="$availh$sizeh"
- title="$prefix$device"
-
- pbar -n $used $size "$title" "$misc"
-done