summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Ehlert2020-01-10 13:39:42 +0100
committerSebastian Ehlert2020-01-10 13:40:35 +0100
commita8947fb60f1b6d192046cb91c7c0524fd4470885 (patch)
treec091c654a2e25b47e42a6ed182791663bfc9c383
downloadaur-a8947fb60f1b6d192046cb91c7c0524fd4470885.tar.gz
initial version of DFT-D4 stable package
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
-rw-r--r--dftd4-build.patch13
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba38c0e5e54e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = dftd4
+ pkgdesc = A Generally Applicable Atomic-Charge Dependent London Dispersion Correction
+ pkgver = 2.4.0
+ pkgrel = 1
+ url = https://github.com/dftd4/dftd4
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ depends = gcc-fortran
+ depends = openblas
+ depends = lapack
+ source = dftd4::https://github.com/dftd4/dftd4/archive/v2.4.0.tar.gz
+ source = dftd4-build.patch
+ md5sums = 97602f1a1239528f6e2487f31607c1e0
+ md5sums = f69b8bac09b6f4dd29b1aaca763913c7
+ sha256sums = 6c3c8e07a4574ed5f54275944596a9845c38a9ed6c7217dc8769ebf95340bee9
+ sha256sums = 36ce3527ec42095836a84b5aa4050acab602b9fca5eb95ea20bf28c299d086f7
+
+pkgname = dftd4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93c15a0b3828
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Sebastian Ehlert <awvwgk at gmail dot com>
+
+pkgname=dftd4
+pkgver=2.4.0
+pkgrel=1
+arch=('x86_64')
+url="https://github.com/dftd4/dftd4"
+depends=('gcc-fortran' 'openblas' 'lapack')
+makedepends=('git' 'meson' 'ninja')
+license=('LGPL3')
+pkgdesc="A Generally Applicable Atomic-Charge Dependent London Dispersion Correction"
+source=("${pkgname}::https://github.com/dftd4/dftd4/archive/v2.4.0.tar.gz"
+ "dftd4-build.patch")
+sha256sums=('6c3c8e07a4574ed5f54275944596a9845c38a9ed6c7217dc8769ebf95340bee9'
+ '36ce3527ec42095836a84b5aa4050acab602b9fca5eb95ea20bf28c299d086f7')
+md5sums=('97602f1a1239528f6e2487f31607c1e0'
+ 'f69b8bac09b6f4dd29b1aaca763913c7')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch < "${srcdir}"/dftd4-build.patch
+ mkdir -p "${srcdir}/${pkgname}-${pkgver}"/_build
+ cd "${srcdir}/${pkgname}-${pkgver}"/_build
+ meson setup . .. \
+ --buildtype release \
+ --warnlevel 0 \
+ --prefix=/usr \
+ -Dla_backend=openblas
+ ninja
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"/_build
+ DESTDIR="$pkgdir" ninja install
+}
diff --git a/dftd4-build.patch b/dftd4-build.patch
new file mode 100644
index 000000000000..f9486c492c8c
--- /dev/null
+++ b/dftd4-build.patch
@@ -0,0 +1,13 @@
+diff --git a/meson.build b/meson.build
+index ea1685c..2f0479b 100644
+--- a/meson.build
++++ b/meson.build
+@@ -6,7 +6,7 @@ project('dftd4', 'fortran',
+
+ conf = configuration_data()
+ conf.set('version', meson.project_version())
+-conf.set('commit', run_command(find_program('git'),'show','-s','--format=%h').stdout().strip())
++conf.set('commit', 'aur')
+ conf.set('date', run_command(find_program('date'),'-I').stdout().strip())
+ conf.set('author', run_command(find_program('whoami')).stdout().strip())
+ conf.set('origin', run_command(find_program('hostname')).stdout().strip())