summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Ivanov2018-03-18 09:34:33 +0100
committerPeter Ivanov2018-03-18 09:34:33 +0100
commit2e5af4f2b0dc17fc4d5fcf4b73e64290ec44ee4d (patch)
tree2d260aeaa99032fc52c528bdd0f652f36b797252
downloadaur-2e5af4f2b0dc17fc4d5fcf4b73e64290ec44ee4d.tar.gz
Initial commit.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
-rw-r--r--dfu-util.install11
-rwxr-xr-xpre-commit5
-rw-r--r--stm32dfu.udev.rules10
5 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8cddfe05e53d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Mar 18 08:34:33 UTC 2018
+pkgbase = dfu-util-git
+ pkgdesc = Tool intended to download and upload firmware using DFU protocol to devices connected over USB
+ pkgver = 20170603
+ pkgrel = 1
+ url = http://dfu-util.gnumonks.org
+ install = dfu-util.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = libusb
+ conflicts = dfu-util
+ source = stm32dfu.udev.rules
+ source = dfu-util::git://git.code.sf.net/p/dfu-util/dfu-util
+ sha256sums = 64d4314f354d965e3dc0fd439dc497d5d0a41bf649da1869df40f93718e5a6fe
+ sha256sums = SKIP
+
+pkgname = dfu-util-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6c962ff390d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id$
+# Maintainer: Peter Ivanov <ivanovp@gmail.com>
+# Contributor: Anatol Pomozov <anatol.pomozov@gmail.com>
+# Contributor: Øyvind 'Mr.Elendig' Heggstad <mrelendig@har-ikkje.net>
+# Contributor: Fabrizio Antonangeli <fabrizio.antonangeli@gmail.com>
+
+pkgname=dfu-util-git
+pkgver=20170603
+pkgrel=1
+pkgdesc='Tool intended to download and upload firmware using DFU protocol to devices connected over USB'
+url='http://dfu-util.gnumonks.org'
+license=(GPL2)
+arch=('i686' 'x86_64')
+depends=('libusb')
+conflicts=('dfu-util')
+install=dfu-util.install
+_gitroot=git://git.code.sf.net/p/dfu-util/dfu-util
+_gitname=dfu-util
+source=("stm32dfu.udev.rules"
+ "$_gitname::$_gitroot")
+sha256sums=('64d4314f354d965e3dc0fd439dc497d5d0a41bf649da1869df40f93718e5a6fe'
+ 'SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git log -1 --format="%cd" --date=short | tr -d '-'
+}
+
+build() {
+ cd $_gitname
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $_gitname
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir"/stm32dfu.udev.rules "$pkgdir"/usr/lib/udev/rules.d/48-stm32dfu.rules
+}
diff --git a/dfu-util.install b/dfu-util.install
new file mode 100644
index 000000000000..38cc149a9eea
--- /dev/null
+++ b/dfu-util.install
@@ -0,0 +1,11 @@
+post_install() {
+ udevadm control --reload-rules
+}
+
+post_upgrade() {
+ udevadm control --reload-rules
+}
+
+post_remove() {
+ udevadm control --reload-rules
+}
diff --git a/pre-commit b/pre-commit
new file mode 100755
index 000000000000..3c02b611e1ef
--- /dev/null
+++ b/pre-commit
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+mksrcinfo
+git add -f .SRCINFO
+exit 0
diff --git a/stm32dfu.udev.rules b/stm32dfu.udev.rules
new file mode 100644
index 000000000000..138ddc4258b5
--- /dev/null
+++ b/stm32dfu.udev.rules
@@ -0,0 +1,10 @@
+# stm32 boards, with onboard DFU support
+
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="0483", ATTRS{idProduct}=="df11", \
+ MODE:="0666", \
+ SYMLINK+="stm32_dfu"
+
+# If you share your linux system with other users, or just don't like the
+# idea of write permission for everybody, you can replace MODE:="0666" with
+# OWNER:="yourusername" to create the device owned by you, or with
+# GROUP:="somegroupname" and mange access using standard unix groups.