summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent PRELAT2015-06-27 11:26:13 +0200
committerVincent PRELAT2015-06-27 11:26:13 +0200
commit112c2b08b001af642352cb3820cf4853c0300215 (patch)
tree4d90bf67f443e283fd6ff33be4f9dacfa1bebd31
downloadaur-112c2b08b001af642352cb3820cf4853c0300215.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1318c99866a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dg100ctl
+ pkgdesc = Program to configure the GlobalSat DG-100 GPS data logger
+ pkgver = 0.1
+ pkgrel = 2
+ url = http://xpg.dk/projects/dg100ctl
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = qt4
+ source = http://launchpad.net/dg100ctl/trunk/0.1/+download/dg100ctl-0.1.tar.bz2
+ md5sums = 07008d7366148c2e1811ca20f8ccd9c4
+
+pkgname = dg100ctl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a47b950140dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Vincent Prelat <prelatv [at] gmail.com>
+
+pkgname=dg100ctl
+pkgver=0.1
+pkgrel=2
+pkgdesc="Program to configure the GlobalSat DG-100 GPS data logger"
+url="http://xpg.dk/projects/dg100ctl"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('qt4')
+makedepends=('cmake')
+source=(http://launchpad.net/$pkgname/trunk/$pkgver/+download/$pkgname-$pkgver.tar.bz2)
+md5sums=('07008d7366148c2e1811ca20f8ccd9c4')
+
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+
+ mkdir build
+ cd build
+ cmake -D QT_QMAKE_EXECUTABLE=qmake4 -D CMAKE_INSTALL_PREFIX=/usr .. || return 1
+ make || return 1
+ make DESTDIR=$startdir/pkg install || return 1
+
+}
+