summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Eklind2018-11-25 13:59:53 +0100
committerRobin Eklind2018-11-25 13:59:53 +0100
commitf461c86af461489ae3e13fa8d9a0f0b1da58a0ec (patch)
tree86d19d5e26dd69edfb3ed7abf4772924c9d3ad87
downloadaur-f461c86af461489ae3e13fa8d9a0f0b1da58a0ec.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..538df16584bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = dgengine-physfs-git
+ pkgdesc = PhysicsFS with MPQ files support
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/dgengin/physfs
+ arch = i686
+ arch = x86_64
+ license = ZLIB
+ makedepends = cmake
+ makedepends = git
+ depends = zlib
+ provides = physfs
+ conflicts = physfs
+ source = dgengine-physfs-git::git+https://github.com/dgengin/physfs.git
+ sha1sums = SKIP
+
+pkgname = dgengine-physfs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a777934d736d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=dgengine-physfs-git
+pkgver=1
+pkgrel=1
+pkgdesc="PhysicsFS with MPQ files support"
+arch=('i686' 'x86_64')
+url="https://github.com/dgengin/physfs"
+license=('ZLIB')
+depends=('zlib')
+makedepends=('cmake' 'git')
+source=("${pkgname}::git+https://github.com/dgengin/physfs.git")
+sha1sums=('SKIP')
+provides=("physfs")
+conflicts=("physfs")
+
+build() {
+ mkdir build
+ cd build
+ cmake ../${pkgname} -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DPHYSFS_BUILD_TEST=OFF
+ make all
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+ install -d "${pkgdir}"/usr/share/physfs
+}