summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-10-07 20:57:35 +0200
committersL1pKn072021-10-07 20:57:35 +0200
commit06ce480c375a71df5b1a4216bbce475fb882fc42 (patch)
tree6f36994f0cc987f8cabf3a6ce8176a107369c6c1
downloadaur-06ce480c375a71df5b1a4216bbce475fb882fc42.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD52
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e9729758ad9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = dgnvindex-bin
+ pkgdesc = AVC/HEVC/MPG/VC1 Decoder and Frame Server
+ pkgver = 2.31
+ pkgrel = 1
+ url = http://rationalqm.us/dgdecnv/dgdecnv.html
+ arch = x86_64
+ license = custom::Donald A. Graft
+ provides = dgnvindex
+ provides = vapoursynth-plugin-dgdecodenv
+ conflicts = dgnvindex
+ conflicts = vapoursynth-plugin-dgdecodenv
+ source = http://rationalqm.us/dgdecnv/binaries/dgdecnv_linux_231.zip
+ sha256sums = b867550f31a2f50db48b1e69e6d37c5ccb04deac4e7216c0a634962c4b3c0971
+
+pkgname = dgnvindex-bin
+ pkgdesc = AVC/HEVC/MPG/VC1 Decoder and Frame Server
+ depends = cuda
+
+pkgname = vapoursynth-plugin-dgdecodenv-bin
+ pkgdesc = Plugin for Vapoursynth: dgdecodenv (GIT version)
+ depends = vapoursynth
+ depends = cuda
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ae2aae3549f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=dgdecodenv
+pkgbase=dgnvindex-bin
+pkgname=('dgnvindex-bin'
+ "vapoursynth-plugin-${_plug}-bin"
+# "avisynth-plugin-${_plug}-bin"
+ )
+pkgver=2.31
+pkgrel=1
+pkgdesc="AVC/HEVC/MPG/VC1 Decoder and Frame Server"
+arch=('x86_64')
+url='http://rationalqm.us/dgdecnv/dgdecnv.html'
+license=('custom::Donald A. Graft')
+provides=('dgnvindex'
+ 'vapoursynth-plugin-dgdecodenv'
+ )
+conflicts=('dgnvindex'
+ 'vapoursynth-plugin-dgdecodenv'
+ )
+source=("http://rationalqm.us/dgdecnv/binaries/dgdecnv_linux_${pkgver/./}.zip")
+sha256sums=('b867550f31a2f50db48b1e69e6d37c5ccb04deac4e7216c0a634962c4b3c0971')
+
+package_dgnvindex-bin() {
+ pkgdesc="AVC/HEVC/MPG/VC1 Decoder and Frame Server"
+ depends=('cuda')
+
+ install -Dm755 dgindexnv "${pkgdir}/usr/bin/dgindexnv"
+
+ install -Dm644 LinuxUserManual.txt "${pkgdir}/usr/share/doc/${pkgname}/LinuxUserManual.txt"
+ install -Dm644 LinuxLimitations.txt "${pkgdir}/usr/share/doc/${pkgname}/LinuxLimitations.txt"
+}
+
+package_vapoursynth-plugin-dgdecodenv-bin() {
+ pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+ depends=('vapoursynth'
+ 'cuda'
+ )
+
+ install -Dm755 libdgdecodenv.so "${pkgdir}/usr/lib/vapoursynth/libdgdecodenv.so"
+ install -Dm644 LinuxUserManual.txt "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/LinuxUserManual.txt"
+}
+
+package_avisynth-plugin-dgdecodenv-bin() {
+ pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
+ depends=('avisynthplus'
+ 'cuda'
+ )
+
+ install -Dm755 libdgdecodenv.so "${pkgdir}/usr/lib/avisynth/libdgdecodenv.so"
+ install -Dm644 LinuxUserManual.txt "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/LinuxUserManual.txt"
+} \ No newline at end of file