summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaley Main2017-12-14 20:59:08 +1100
committerKaley Main2017-12-14 20:59:08 +1100
commit923c8b228cbf544129a4a3a91d59f33c79b95966 (patch)
tree8a9e92c7b6fae25e4d5df477b97ba5a7341ee39c
parent1f0e43d15ebf8495fa2ca1c848fb62c4327b9313 (diff)
downloadaur-923c8b228cbf544129a4a3a91d59f33c79b95966.tar.gz
Upgrade to 0.9.4
-rw-r--r--PKGBUILD12
-rw-r--r--dgraph-zero.service11
-rw-r--r--dgraph.service4
3 files changed, 20 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a3b60045f35c..e3356409cc63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
pkgname=dgraph-bin
_pkgname=dgraph
-pkgver=0.7.7
+pkgver=0.9.4
pkgrel=1
pkgdesc='a low latency, high throughput, native and distributed graph database'
arch=('x86_64')
url='https://github.com/dgraph-io/dgraph'
license=('APACHE')
#depends=('gcc-libs')
-source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/dgraph-io/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-linux-amd64-v${pkgver}.tar.gz" 'dgraph.service')
-sha256sums=('a46c83c21bc2d9c70dd2fd26695123a70ae4a66d6b1902bb8f037118e2dcb18b' '8bde63f163c6a925ecb884ca12aede192a307693042ff7dddf230d3e4ec2fd7e')
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/dgraph-io/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-linux-amd64-v${pkgver}.tar.gz" 'dgraph.service' 'dgraph-zero.service')
+sha256sums=('29d96e3f0b794c3f710320aad8c7a0b867f16ccf292f062724efc02e308088a5' '6b9e93aa8cc93fd2d163e9fe963bbde998f624fdf7a558b664079bedcb716444' 'b917a94ad1ccf6a5831bf103ccdfac64bfdc617ef00ddf8840069de3e31962bc')
package() {
- cd "$srcdir/dgraph"
- for binary in dgraph dgraphloader; do
+ cd "$srcdir"
+ for binary in dgraph; do
install -Dm755 $binary "$pkgdir/usr/bin/$binary"
done
- cd "$srcdir"
install -Dm644 dgraph.service "$pkgdir/usr/lib/systemd/system/dgraph.service"
+ install -Dm644 dgraph-zero.service "$pkgdir/usr/lib/systemd/system/dgraph-zero.service"
install -d "$pkgdir/var/lib/dgraph/data"
}
diff --git a/dgraph-zero.service b/dgraph-zero.service
new file mode 100644
index 000000000000..6c871740d40a
--- /dev/null
+++ b/dgraph-zero.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Dgraph database
+
+[Service]
+ExecStart=/usr/bin/dgraph zero --port_offset -2000
+Restart=on-failure
+RestartSec=1
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/dgraph.service b/dgraph.service
index 8422436be435..b7b8fc014b73 100644
--- a/dgraph.service
+++ b/dgraph.service
@@ -1,8 +1,10 @@
[Unit]
Description=Dgraph database
+Requires=dgraph-zero.service
+After=dgraph-zero.service
[Service]
-ExecStart=/usr/bin/dgraph -w /var/lib/dgraph/data/w -p /var/lib/dgraph/data/p
+ExecStart=/usr/bin/dgraph server --memory_mb=2048 -w /var/lib/dgraph/data/w -p /var/lib/dgraph/data/p --zero localhost:5080
Restart=on-failure
RestartSec=1