summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Trengrove2016-11-11 22:20:34 +1100
committerJohn Trengrove2016-11-11 22:20:34 +1100
commit2c59c543b24288878bbc12d47e316b5b48229f4d (patch)
treef82ffe8afe79dde5ef082653ac86a46a9e71be0b
downloadaur-2c59c543b24288878bbc12d47e316b5b48229f4d.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34f6ea914a2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = dgraph-git
+ pkgdesc = a low latency, high throughput, native and distributed graph database
+ pkgver = 20161026
+ pkgrel = 2
+ url = https://github.com/dgraph-io/dgraph
+ arch = x86_64
+ arch = i686
+ license = APACHE
+ depends = gcc-libs
+ depends = go
+ depends = icu
+ depends = rocksdb
+ provides = dgraph
+ conflicts = dgraph dgraph-bin
+ options = !strip
+ options = !emptydirs
+
+pkgname = dgraph-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f495294f320
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: John Trengrove <john@retrofilter.com>
+
+pkgname=dgraph-git
+pkgver=20161026
+pkgrel=2
+pkgdesc='a low latency, high throughput, native and distributed graph database'
+arch=('x86_64' 'i686')
+url='https://github.com/dgraph-io/dgraph'
+license=('APACHE')
+conflicts=('dgraph dgraph-bin')
+provides=('dgraph')
+options=('!strip' '!emptydirs')
+depends=('gcc-libs' 'go' 'icu' 'rocksdb')
+
+build() {
+ GOPATH="$srcdir" go get -v github.com/dgraph-io/dgraph/...
+}
+
+package() {
+ cd "$srcdir"
+ for binary in dgraph dgraphlist dgraphloader; do
+ install -Dm755 bin/$binary "$pkgdir/usr/bin/$binary"
+ done
+}
+
+# vim:set ts=2 sw=2 et: