summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2013-10-07 15:26:46 +0200
committerJohannes Dewender2013-10-07 15:26:46 +0200
commit622ecf061d0734bdcc2d2885583d4628fa5d77ba (patch)
tree6af72be162c08c183ab08cadaa48336145c0184b
downloadaur-622ecf061d0734bdcc2d2885583d4628fa5d77ba.tar.gz
add dh-autoreconf as version 9
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD21
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c079e181faf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dh-autoreconf
+ pkgdesc = debhelper add-on to call autoreconf and clean up after the build
+ pkgver = 9
+ pkgrel = 1
+ url = http://packages.debian.org/sid/dh-make
+ arch = any
+ license = GPL
+ depends = debhelper
+ depends = perl
+ source = http://ftp.debian.org/debian/pool/main/d/dh-autoreconf/dh-autoreconf_9.tar.gz
+ md5sums = 8ee1d5b7f31c36de89ec37c81ae54973
+
+pkgname = dh-autoreconf
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bd9b4a41adc0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*.tar.gz
+*.tar.xz
+*.tgz
+*.rpm
+*.zip
+*.bz2
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9f7144ab435
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Johannes Dewender arch at JonnyJD dot net
+pkgname=dh-autoreconf
+pkgver=9
+pkgrel=1
+pkgdesc="debhelper add-on to call autoreconf and clean up after the build"
+arch=('any')
+url="http://packages.debian.org/sid/dh-make"
+license=('GPL')
+depends=('debhelper' 'perl')
+source=(http://ftp.debian.org/debian/pool/main/d/$pkgname/${pkgname}_$pkgver.tar.gz)
+md5sums=('8ee1d5b7f31c36de89ec37c81ae54973')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -D "dh_autoreconf" "$pkgdir/usr/bin/dh_autoreconf"
+ install -D "dh_autoreconf_clean" "$pkgdir/usr/bin/dh_autoreconf_clean"
+ install -D -m 644 autoreconf.pm \
+ "$pkgdir/usr/share/perl5/vendor_perl/Debian/Debhelper/Sequence/autoreconf.pm"
+}
+
+# vim:set ts=2 sw=2 et: