summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent BESANCON2015-09-19 23:12:26 +0200
committerVincent BESANCON2015-09-19 23:12:26 +0200
commitda9e99a1fea1dcb5bcf27c6f0aabf5f8462261ad (patch)
tree4283d068b7d91c31784742ab3202bba0df20a07f
downloadaur-da9e99a1fea1dcb5bcf27c6f0aabf5f8462261ad.tar.gz
Initial commit.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..822af1374581
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = dh-virtualenv-git
+ pkgdesc = Python virtualenvs in Debian packages (git version)
+ pkgver = 0.10.r0.gb3ed15e
+ pkgrel = 1
+ url = https://github.com/spotify/dh-virtualenv
+ arch = any
+ license = GPL2
+ makedepends = python
+ makedepends = python-setuptools
+ makedepends = git
+ depends = debhelper
+ depends = python-virtualenv
+ provides = dh-virtualenv
+ conflicts = dh-virtualenv
+ source = git+https://github.com/spotify/dh-virtualenv
+ md5sums = SKIP
+
+pkgname = dh-virtualenv-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a4d66a87cc78
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/dh-virtualenv
+/pkg
+/src
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8de427a86839
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Vincent BESANCON <besancon.vincent@gmail.com>
+pkgname=dh-virtualenv-git
+_gitname=dh-virtualenv
+pkgver=0.10.r0.gb3ed15e
+pkgrel=1
+pkgdesc='Python virtualenvs in Debian packages (git version)'
+arch=('any')
+url='https://github.com/spotify/dh-virtualenv'
+license=('GPL2')
+source=("git+https://github.com/spotify/${_gitname}")
+md5sums=('SKIP')
+depends=(
+ 'debhelper'
+ 'python-virtualenv'
+)
+makedepends=(
+ 'python'
+ 'python-setuptools'
+ 'git'
+)
+provides=('dh-virtualenv')
+conflicts=('dh-virtualenv')
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -d "${pkgdir}/usr/share/perl5/vendor_perl"
+ cp -r lib/* "${pkgdir}/usr/share/perl5/vendor_perl"
+ install -D -m644 -t \
+ "${pkgdir}/usr/share/debhelper/autoscripts" autoscripts/*-dh-virtualenv
+ install -D -m644 LICENSE \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^v//'
+}