summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramesgen2020-08-13 00:42:07 +0200
committeramesgen2020-08-13 00:42:34 +0200
commit16ef7c7404db7d5f9c32d050149386316ec9f144 (patch)
treec3383912ceec218000057b3c7b51af9923f4a70b
parenta12f16ed93ca8813c14767f2556f142dd6ae0957 (diff)
downloadaur-16ef7c7404db7d5f9c32d050149386316ec9f144.tar.gz
update to 1.7.1 (Dhall 1.34.0) & add shell completions
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD31
3 files changed, 26 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 423a5ef19fe3..95c7d8bdd105 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = dhall-json-bin
pkgdesc = Dhall to JSON compiler and a Dhall to YAML compiler
- pkgver = 1.7.0
+ pkgver = 1.7.1
pkgrel = 1
url = https://github.com/dhall-lang/dhall-haskell
arch = x86_64
license = BSD
- source = https://github.com/dhall-lang/dhall-haskell/releases/download/1.33.1/dhall-json-1.7.0-x86_64-linux.tar.bz2
- source = https://raw.githubusercontent.com/dhall-lang/dhall-haskell/1.33.1/dhall-json/LICENSE
- sha256sums = SKIP
- sha256sums = SKIP
+ source = dhall-json-1.34.0-1.7.1.tar.bz2::https://github.com/dhall-lang/dhall-haskell/releases/download/1.34.0/dhall-json-1.7.1-x86_64-linux.tar.bz2
+ source = LICENSE-1.7.1::https://raw.githubusercontent.com/dhall-lang/dhall-haskell/1.34.0/dhall-json/LICENSE
+ sha256sums = 37a7df3c0f1073cf58c0b28c13454f113a5a9af63913b9faf2a8928aa9d88293
+ sha256sums = 91f68ca8606e7ae993148187e397e20431aa6d870ac9fcc70330a0479468eef9
pkgname = dhall-json-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
index 31e47fde08ef..dfc78b218766 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,32 @@
# Maintainer: Jan Rydzewski <flegmer@gmail.com>
+# Maintainer: amesgen <amesgen AT amesgen DOT de>
pkgname='dhall-json-bin'
-pkgver=1.7.0
+pkgver=1.7.1
pkgrel=1
pkgdesc="Dhall to JSON compiler and a Dhall to YAML compiler"
arch=('x86_64')
url='https://github.com/dhall-lang/dhall-haskell'
license=('BSD')
-_dhall_ver=1.33.1
+_dhall_ver=1.34.0
-source=("https://github.com/dhall-lang/dhall-haskell/releases/download/$_dhall_ver/dhall-json-$pkgver-x86_64-linux.tar.bz2"
- "https://raw.githubusercontent.com/dhall-lang/dhall-haskell/$_dhall_ver/dhall-json/LICENSE")
-sha256sums=("SKIP"
- "SKIP")
+source=("dhall-json-$_dhall_ver-$pkgver.tar.bz2::https://github.com/dhall-lang/dhall-haskell/releases/download/$_dhall_ver/dhall-json-$pkgver-x86_64-linux.tar.bz2"
+ "LICENSE-$pkgver::https://raw.githubusercontent.com/dhall-lang/dhall-haskell/$_dhall_ver/dhall-json/LICENSE")
+sha256sums=('37a7df3c0f1073cf58c0b28c13454f113a5a9af63913b9faf2a8928aa9d88293'
+ '91f68ca8606e7ae993148187e397e20431aa6d870ac9fcc70330a0479468eef9')
-function package {
- install -Dt "$pkgdir/usr/bin/" "$srcdir/bin/dhall-to-json"
- install -Dt "$pkgdir/usr/bin/" "$srcdir/bin/dhall-to-yaml"
- install -Dt "$pkgdir/usr/bin/" "$srcdir/bin/json-to-dhall"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+package() {
+ install -Dm644 LICENSE-$pkgver "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ for f in dhall-to-json dhall-to-yaml json-to-dhall; do
+ install -Dm755 "$srcdir/bin/$f" -t "$pkgdir/usr/bin/"
+ _install_completion_script $f bash bash-completion/completions/$f
+ _install_completion_script $f zsh zsh/site-functions/_$f
+ _install_completion_script $f fish fish/vendor_completions.d/$f.fish
+ done
+}
+
+_install_completion_script() {
+ install -Dm644 <("$pkgdir/usr/bin/$1" --$2-completion-script "/usr/bin/$1") "$pkgdir/usr/share/$3"
}