summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Rydzewski2019-03-30 11:41:06 +0100
committerJan Rydzewski2019-03-30 11:41:06 +0100
commitf7b37ed2a2354d04668fd5987cdcc5bcbdaea1f9 (patch)
treeb2df757caf5305bf6fbaf3beb828e66e950ba4f9
downloadaur-f7b37ed2a2354d04668fd5987cdcc5bcbdaea1f9.tar.gz
initial
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74f75e02184a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dhall-json-bin
+ pkgdesc = Dhall to JSON compiler and a Dhall to YAML compiler
+ pkgver = 1.2.7
+ pkgrel = 1
+ url = https://github.com/dhall-lang/dhall-haskell
+ arch = x86_64
+ license = BSD
+ source = https://github.com/dhall-lang/dhall-haskell/releases/download/1.21.0/dhall-json-1.2.7-x86_64-linux.tar.bz2
+ source = https://raw.githubusercontent.com/dhall-lang/dhall-haskell/1.21.0/dhall-json/LICENSE
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = dhall-json-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e16c268bff01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Jan Rydzewski <flegmer@gmail.com>
+
+pkgname='dhall-json-bin'
+pkgver=1.2.7
+pkgrel=1
+pkgdesc="Dhall to JSON compiler and a Dhall to YAML compiler"
+arch=('x86_64')
+url='https://github.com/dhall-lang/dhall-haskell'
+license=('BSD')
+
+_dhall_ver=1.21.0
+
+source=("https://github.com/dhall-lang/dhall-haskell/releases/download/$_dhall_ver/dhall-json-$pkgver-x86_64-linux.tar.bz2"
+ "https://raw.githubusercontent.com/dhall-lang/dhall-haskell/$_dhall_ver/dhall-json/LICENSE")
+sha256sums=("SKIP"
+ "SKIP")
+
+function package {
+ install -Dt "$pkgdir/usr/bin/" "$srcdir/bin/dhall-to-json"
+ install -Dt "$pkgdir/usr/bin/" "$srcdir/bin/dhall-to-yaml"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}