summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkpcyrd2017-11-02 00:47:27 +0100
committerkpcyrd2017-11-02 00:47:27 +0100
commit49ccece192ac8407bfc759923d98b69e959a0e61 (patch)
treeaaee1b1a6618c9f2eb0f61d1cbfd9de99892eec4
parentdfd9589ef29989efd082fa24f9ba3c895d2c46f8 (diff)
downloadaur-49ccece192ac8407bfc759923d98b69e959a0e61.tar.gz
v0.8.0-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03b82cb748eb..0d45ca2c800b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = dhcpcanon
pkgdesc = DHCP client disclosing less identifying information
pkgver = 0.8.0
- pkgrel = 1
+ pkgrel = 2
url = https://dhcpcanon.readthedocs.io
arch = any
license = MIT
+ checkdepends = python-pytest
depends = python-setuptools
depends = python-attrs
depends = python-dbus
depends = python-netaddr
depends = python-lockfile
depends = python-pyroute2
- depends = scapy
depends = scapy3k
source = dhcpcanon-0.8.0.tar.gz::https://github.com/juga0/dhcpcanon/archive/v0.8.0.tar.gz
sha512sums = 44b08c861e7195da6ac04fb2fbfc0bca47aef1462bc46ddfb857048289817af0a09d1fe5171528d050dd3d3d78e7b7c8d63b9743051e7da7fa14859d9b632673
diff --git a/PKGBUILD b/PKGBUILD
index 0e8af9783ec0..ea97738b8f72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
pkgname=dhcpcanon
pkgver=0.8.0
-pkgrel=1
+pkgrel=2
pkgdesc='DHCP client disclosing less identifying information'
url='https://dhcpcanon.readthedocs.io'
license=('MIT')
arch=('any')
-depends=('python-setuptools' 'python-attrs' 'python-dbus' 'python-netaddr' 'python-lockfile' 'python-pyroute2' 'scapy' 'scapy3k')
+depends=('python-setuptools' 'python-attrs' 'python-dbus' 'python-netaddr' 'python-lockfile' 'python-pyroute2' 'scapy3k')
+checkdepends=('python-pytest')
source=(${pkgname}-${pkgver}.tar.gz::https://github.com/juga0/dhcpcanon/archive/v${pkgver}.tar.gz)
sha512sums=('44b08c861e7195da6ac04fb2fbfc0bca47aef1462bc46ddfb857048289817af0a09d1fe5171528d050dd3d3d78e7b7c8d63b9743051e7da7fa14859d9b632673')
@@ -16,11 +17,16 @@ build() {
python setup.py build
}
+check() {
+ cd ${pkgname}-${pkgver}
+ py.test
+}
+
package() {
cd ${pkgname}-${pkgver}
python setup.py install --prefix=/usr --root="${pkgdir}" -O1 --skip-build
- install -Dm 755 sbin/dhcpcanon-script -t "${pkgdir}/usr/sbin"
+ install -Dm 755 sbin/dhcpcanon-script -t "${pkgdir}/usr/bin"
install -Dm 644 systemd/dhcpcanon.service -t "${pkgdir}/usr/lib/systemd/system"
install -Dm 644 systemd/network/90-dhcpcanon.link -t "${pkgdir}/lib/systemd/network"
install -Dm 644 tmpfiles.d/dhcpcanon.conf -t "${pkgdir}/usr/lib/tmpfiles.d"
@@ -28,7 +34,7 @@ package() {
install -Dm 644 man/dhcpcanon.8 man/dhcpcanon-script.8 -t "${pkgdir}/usr/share/man/man8"
install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
-
+ install -Dm 644 LICENSE "/usr/share/licenses/${pkgname}"
}
# vim: ts=2 sw=2 et: