summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkpcyrd2019-02-09 14:28:57 +0100
committerkpcyrd2019-02-09 14:28:57 +0100
commit780d6496592f6b1632db9347e326f1c9000245fb (patch)
treeee3ecc0e277c6c08e04381d758e2e4b368ebfffa
parent817cc8c53b2ef2749a40282184aeb53155fcbaa4 (diff)
downloadaur-780d6496592f6b1632db9347e326f1c9000245fb.tar.gz
Fix dependencies
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2df917fb95dc..b71c7f51fb52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = dhcpcanon
pkgdesc = DHCP client disclosing less identifying information
pkgver = 0.8.5
- pkgrel = 1
- url = https://dhcpcanon.readthedocs.io
+ pkgrel = 3
+ url = https://dhcpap.tech/
arch = any
license = MIT
checkdepends = python-pytest
@@ -12,7 +12,7 @@ pkgbase = dhcpcanon
depends = python-netaddr
depends = python-lockfile
depends = python-pyroute2
- depends = scapy3k
+ depends = python-scapy
source = dhcpcanon-0.8.5.tar.gz::https://github.com/juga0/dhcpcanon/archive/v0.8.5.tar.gz
sha512sums = 2ab42c16749f355727d82f9876350a61ef220a6ba3a45d4cbde84a8b484b26275089950872e5bf34ca9a022a866f8636fc5d91dd2755bf339b0c5a4e7b7f20be
diff --git a/PKGBUILD b/PKGBUILD
index 073a0171622d..8e68a67c5e4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,39 +2,39 @@
pkgname=dhcpcanon
pkgver=0.8.5
-pkgrel=1
+pkgrel=3
pkgdesc='DHCP client disclosing less identifying information'
-url='https://dhcpcanon.readthedocs.io'
+url='https://dhcpap.tech/'
license=('MIT')
arch=('any')
-depends=('python-setuptools' 'python-attrs' 'python-dbus' 'python-netaddr' 'python-lockfile' 'python-pyroute2' 'scapy3k')
+depends=('python-setuptools' 'python-attrs' 'python-dbus' 'python-netaddr' 'python-lockfile' 'python-pyroute2' 'python-scapy')
checkdepends=('python-pytest')
-source=(${pkgname}-${pkgver}.tar.gz::https://github.com/juga0/dhcpcanon/archive/v${pkgver}.tar.gz)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/juga0/dhcpcanon/archive/v${pkgver}.tar.gz")
sha512sums=('2ab42c16749f355727d82f9876350a61ef220a6ba3a45d4cbde84a8b484b26275089950872e5bf34ca9a022a866f8636fc5d91dd2755bf339b0c5a4e7b7f20be')
build() {
- cd ${pkgname}-${pkgver}
+ cd "${pkgname}-${pkgver}"
python setup.py build
}
check() {
- cd ${pkgname}-${pkgver}
- py.test
+ cd "${pkgname}-${pkgver}"
+ PYTHONPATH=. py.test
}
package() {
- cd ${pkgname}-${pkgver}
+ cd "${pkgname}-${pkgver}"
python setup.py install --prefix=/usr --root="${pkgdir}" -O1 --skip-build
install -Dm 755 sbin/dhcpcanon-script -t "${pkgdir}/usr/bin"
install -Dm 644 systemd/dhcpcanon.service -t "${pkgdir}/usr/lib/systemd/system"
- install -Dm 644 systemd/network/90-dhcpcanon.link -t "${pkgdir}/lib/systemd/network"
+ install -Dm 644 systemd/network/90-dhcpcanon.link -t "${pkgdir}/usr/lib/systemd/network"
install -Dm 644 tmpfiles.d/dhcpcanon.conf -t "${pkgdir}/usr/lib/tmpfiles.d"
install -Dm 644 apparmor.d/sbin.dhcpcanon -t "${pkgdir}/etc/apparmor.d"
install -Dm 644 man/dhcpcanon.8 man/dhcpcanon-script.8 -t "${pkgdir}/usr/share/man/man8"
- install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
- install -Dm 644 LICENSE "/usr/share/licenses/${pkgname}"
+ install -Dm 644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim: ts=2 sw=2 et: