summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-08 23:14:34 -0600
committerBrian Bidulock2015-07-08 23:14:34 -0600
commit19b4cf2b734ded944beae6583947105f32b8bf97 (patch)
tree5c6f3a647e7a8ea0a8d5bd6590d890df8964891b
downloadaur-19b4cf2b734ded944beae6583947105f32b8bf97.tar.gz
initial version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8d894daceea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dhcpcd-dbus
+ pkgdesc = DBus bindings for dhcpcd
+ pkgver = 0.6.0
+ pkgrel = 2
+ url = http://roy.marples.name/projects/dhcpcd-dbus
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = dbus-core
+ depends = dhcpcd>=5.0
+ source = http://roy.marples.name/downloads/dhcpcd/dhcpcd-dbus-0.6.0.tar.bz2
+ md5sums = 4fd43b0f0ca7c0e65f95a0b2846b37b7
+
+pkgname = dhcpcd-dbus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3a806a56af8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: lth <manuelung@gmail.com>
+# Contributor: nizox <nizzox@gmail.com>
+pkgname=dhcpcd-dbus
+pkgver=0.6.0
+pkgrel=2
+pkgdesc="DBus bindings for dhcpcd"
+url="http://roy.marples.name/projects/dhcpcd-dbus"
+license=("BSD")
+depends=("dbus-core" "dhcpcd>=5.0")
+source=(http://roy.marples.name/downloads/dhcpcd/$pkgname-$pkgver.tar.bz2)
+arch=(i686 x86_64)
+md5sums=('4fd43b0f0ca7c0e65f95a0b2846b37b7')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc/ --libexecdir=/usr/lib/dhcpcd-dbus
+
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR="$pkgdir/" install
+
+ install -d $pkgdir/usr/share/licenses/$pkgname
+}