summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-10-26 02:01:28 +0800
committerChocobo12017-10-26 02:14:46 +0800
commit947778296e447305d0f52f45689951f460c960e9 (patch)
tree2c3c8d8b6dbb926a0d49071ae6310993c264ef30
downloadaur-947778296e447305d0f52f45689951f460c960e9.tar.gz
newpkg: dhcpcd-git 7.0.0.rc3.r16.gef53a17e-1
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD56
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1420b656fc57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = dhcpcd-git
+ pkgdesc = A DHCP and DHCPv6 client
+ pkgver = 7.0.0.rc3.r16.gef53a17e
+ pkgrel = 1
+ url = https://roy.marples.name/projects/dhcpcd
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = glibc
+ optdepends = openresolv: resolvconf support
+ provides = dhcpcd
+ provides = dhcp-client
+ conflicts = dhcpcd
+ options = emptydirs
+ backup = etc/dhcpcd.conf
+ source = git+https://roy.marples.name/git/dhcpcd.git
+ source = dhcpcd.service::https://git.archlinux.org/svntogit/packages.git/plain/trunk/dhcpcd.service?h=packages/dhcpcd
+ source = dhcpcd_.service::https://git.archlinux.org/svntogit/packages.git/plain/trunk/dhcpcd_.service?h=packages/dhcpcd
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = dhcpcd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f0c972120de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=dhcpcd-git
+pkgver=7.0.0.rc3.r16.gef53a17e
+pkgrel=1
+pkgdesc="A DHCP and DHCPv6 client"
+arch=('i686' 'x86_64')
+url="https://roy.marples.name/projects/dhcpcd"
+license=('BSD')
+depends=('glibc')
+makedepends=('git')
+optdepends=('openresolv: resolvconf support')
+provides=('dhcpcd' 'dhcp-client')
+conflicts=('dhcpcd')
+backup=('etc/dhcpcd.conf')
+options=('emptydirs')
+source=("git+https://roy.marples.name/git/dhcpcd.git"
+ "dhcpcd.service::https://git.archlinux.org/svntogit/packages.git/plain/trunk/dhcpcd.service?h=packages/dhcpcd"
+ "dhcpcd_.service::https://git.archlinux.org/svntogit/packages.git/plain/trunk/dhcpcd_.service?h=packages/dhcpcd")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+
+pkgver() {
+ cd "dhcpcd"
+
+ git describe --long --tags | sed 's/^dhcpcd-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "dhcpcd"
+
+ ./configure --prefix="/usr" --sysconfdir="/etc" --sbindir="/usr/bin" \
+ --libexecdir="/usr/lib/dhcpcd" --dbdir="/var/lib/dhcpcd" --rundir="/run"
+ make
+}
+
+check() {
+ cd "dhcpcd"
+
+ make test
+}
+
+package() {
+ cd "dhcpcd"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/dhcpcd/LICENSE"
+
+ # Disable ip4vall
+ echo "noipv4ll" >> "$pkgdir/etc/dhcpcd.conf"
+
+ install -Dm644 "$srcdir/dhcpcd.service" "$pkgdir/usr/lib/systemd/system/dhcpcd.service"
+ install -Dm644 "$srcdir/dhcpcd_.service" "$pkgdir/usr/lib/systemd/system/dhcpcd@.service"
+}