summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-29 09:48:03 +0200
committerChristian Hesse2015-06-29 09:48:03 +0200
commitfc8016bd3f0ea7772a1ebf3039c98b8b50bb3646 (patch)
treeb636980f4b2e12be18d39318f17ed8eabcd67f8f
downloadaur-fc8016bd3f0ea7772a1ebf3039c98b8b50bb3646.tar.gz
initial import of dhcpcd-hook-ntpdate 0.2.0.r2.gc19d363-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d4257340f8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dhcpcd-hook-ntpdate
+ pkgdesc = Hook for dhcpcd to sync time as soon as connection is up
+ pkgver = 0.2.0.r2.gc19d363
+ pkgrel = 1
+ url = https://github.com/eworm-de/dhcpcd-hook-ntpdate
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = ntp
+ depends = dhcpcd
+ source = git://github.com/eworm-de/dhcpcd-hook-ntpdate.git
+ sha256sums = SKIP
+
+pkgname = dhcpcd-hook-ntpdate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66817428547c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=dhcpcd-hook-ntpdate
+pkgver=0.2.0.r2.gc19d363
+pkgrel=1
+pkgdesc="Hook for dhcpcd to sync time as soon as connection is up"
+arch=('any')
+depends=('ntp' 'dhcpcd')
+makedepends=('git')
+url="https://github.com/eworm-de/dhcpcd-hook-ntpdate"
+license=('GPL')
+source=('git://github.com/eworm-de/dhcpcd-hook-ntpdate.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd dhcpcd-hook-ntpdate/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+package() {
+ cd dhcpcd-hook-ntpdate/
+
+ make DESTDIR="${pkgdir}" install
+}
+