summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-29 09:49:02 +0200
committerChristian Hesse2015-06-29 09:49:02 +0200
commitff22a8452d32c952f5535d358404fd8183c230d5 (patch)
tree9d41f4ce210697966ce59c07872a57aec86df8a1
downloadaur-ff22a8452d32c952f5535d358404fd8183c230d5.tar.gz
initial import of dhcpcd-hook-openvpn 0.2.0.r2.gdf48c35-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..809aef58d963
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dhcpcd-hook-openvpn
+ pkgdesc = Hook for dhcpcd to send SIGUSR1 to openvpn and reestablish connection
+ pkgver = 0.2.0.r2.gdf48c35
+ pkgrel = 1
+ url = https://github.com/eworm-de/dhcpcd-hook-openvpn
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = openvpn
+ depends = dhcpcd
+ source = git://github.com/eworm-de/dhcpcd-hook-openvpn.git
+ sha256sums = SKIP
+
+pkgname = dhcpcd-hook-openvpn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..474ae04a692d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=dhcpcd-hook-openvpn
+pkgver=0.2.0.r2.gdf48c35
+pkgrel=1
+pkgdesc="Hook for dhcpcd to send SIGUSR1 to openvpn and reestablish connection"
+arch=('any')
+depends=('openvpn' 'dhcpcd')
+makedepends=('git')
+url="https://github.com/eworm-de/dhcpcd-hook-openvpn"
+license=('GPL')
+source=('git://github.com/eworm-de/dhcpcd-hook-openvpn.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd dhcpcd-hook-openvpn/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+package() {
+ cd dhcpcd-hook-openvpn/
+
+ make DESTDIR="${pkgdir}" install
+}
+