summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-29 09:50:06 +0200
committerChristian Hesse2015-06-29 09:50:06 +0200
commitbc364cc314a08748f36bd4b99a2c20e19d6fc2a6 (patch)
treee00be7da5702ee5a442620b0feb8812f0106b5b6
downloadaur-bc364cc314a08748f36bd4b99a2c20e19d6fc2a6.tar.gz
initial import of dhcpcd-hook-pdnsd 0.2.0.r2.g596c6be-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
-rw-r--r--dhcpcd-hook-pdnsd.install8
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..406830e2a1ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dhcpcd-hook-pdnsd
+ pkgdesc = Hook for dhcpcd to add domain name servers to pdnsd (dns caching proxy)
+ pkgver = 0.2.0.r2.g596c6be
+ pkgrel = 1
+ url = https://github.com/eworm-de/dhcpcd-hook-pdnsd
+ install = dhcpcd-hook-pdnsd.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = pdnsd
+ depends = dhcpcd
+ source = git://github.com/eworm-de/dhcpcd-hook-pdnsd.git
+ sha256sums = SKIP
+
+pkgname = dhcpcd-hook-pdnsd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..340ce6a22294
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=dhcpcd-hook-pdnsd
+pkgver=0.2.0.r2.g596c6be
+pkgrel=1
+pkgdesc="Hook for dhcpcd to add domain name servers to pdnsd (dns caching proxy)"
+arch=('any')
+depends=('pdnsd' 'dhcpcd')
+makedepends=('git')
+url="https://github.com/eworm-de/dhcpcd-hook-pdnsd"
+license=('GPL')
+source=('git://github.com/eworm-de/dhcpcd-hook-pdnsd.git')
+install=dhcpcd-hook-pdnsd.install
+sha256sums=('SKIP')
+
+pkgver() {
+ cd dhcpcd-hook-pdnsd/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+package() {
+ cd dhcpcd-hook-pdnsd/
+
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/dhcpcd-hook-pdnsd.install b/dhcpcd-hook-pdnsd.install
new file mode 100644
index 000000000000..e0a7ef81f280
--- /dev/null
+++ b/dhcpcd-hook-pdnsd.install
@@ -0,0 +1,8 @@
+post_install() {
+ cat<<EOF
+ > You should add an empty server definition to your pdnsd.conf. Please
+ > Take a look at /etc/pdnsd.conf.dhcpcd-hook!
+ > You need to add 'nohook resolv.conf' to your dhcpcd.conf and make
+ > shure your resolv.conf contains an entry to 127.0.0.1!
+EOF
+}