summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-08 23:20:13 -0600
committerBrian Bidulock2015-07-08 23:20:13 -0600
commitcfb57b7653791e837d81226601621b6139b8bf8f (patch)
tree5c9d2645136764f15eea3b8d2229e2adde4e8853
downloadaur-cfb57b7653791e837d81226601621b6139b8bf8f.tar.gz
initial version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--dhcpcd-ui.install11
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..702996d242f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = dhcpcd-ui
+ pkgdesc = dhcpcd Monitor in GTK+
+ pkgver = 0.7.3
+ pkgrel = 1
+ url = http://roy.marples.name/projects/dhcpcd-ui
+ install = dhcpcd-ui.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = gtk2
+ depends = libnotify
+ depends = dhcpcd-dbus>=0.6.0
+ depends = hicolor-icon-theme
+ source = http://roy.marples.name/downloads/dhcpcd/dhcpcd-ui-0.7.3.tar.bz2
+ md5sums = 6cd085cdf7f9c2bd9b98029edc1d712c
+
+pkgname = dhcpcd-ui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b560a9b476ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: lth <manuelung@gmail.com>
+# Contributor: nizox <nizzox@gmail.com>
+pkgname=dhcpcd-ui
+pkgver=0.7.3
+pkgrel=1
+pkgdesc="dhcpcd Monitor in GTK+"
+url="http://roy.marples.name/projects/dhcpcd-ui"
+license=("BSD")
+depends=("gtk2" "libnotify" "dhcpcd-dbus>=0.6.0" "hicolor-icon-theme")
+install=dhcpcd-ui.install
+source=(http://roy.marples.name/downloads/dhcpcd/$pkgname-$pkgver.tar.bz2)
+arch=(i686 x86_64)
+md5sums=('6cd085cdf7f9c2bd9b98029edc1d712c')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr --icondir=/usr/share/icons --without-qt
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR="$pkgdir/" AUTOSTARTDIR=/etc/xdg/autostart install
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ sed -n '1,/^$/p' src/dhcpcd-gtk/main.c \
+ >"$pkgdir/usr/share/licenses/$pkgname/license.txt"
+}
diff --git a/dhcpcd-ui.install b/dhcpcd-ui.install
new file mode 100644
index 000000000000..4852f04d4922
--- /dev/null
+++ b/dhcpcd-ui.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -f -q -t /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}