summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCode Bling2020-10-20 23:51:31 -0400
committerCode Bling2020-10-20 23:51:31 -0400
commit0bd724a2cab5a272aad7679511275ed1d71b3470 (patch)
tree002dd5b5630fd5d90f8c5deaf3517b6586abe5b4
downloadaur-0bd724a2cab5a272aad7679511275ed1d71b3470.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b85934c84ce2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = dhcprobe-git
+ pkgdesc = Retrieve configuration from a DHCP server without having to apply it
+ pkgver = x
+ pkgrel = 1
+ url = https://github.com/JohannesBuchner/DHCProbe
+ arch = any
+ makedepends = git
+ source = https://github.com/JohannesBuchner/DHCProbe
+ sha256sums = SKIP
+
+pkgname = dhcprobe-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5fa472a743a4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/dhcprobe/
+/dhcprobe*.pkg.tar.* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7e547f804c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+_pkgname=dhcprobe
+pkgname=$_pkgname-git
+pkgver=x
+pkgrel=1
+pkgdesc='Retrieve configuration from a DHCP server without having to apply it'
+arch=('any')
+url='https://github.com/JohannesBuchner/DHCProbe'
+makedepends=('git')
+#install=$pkgname.install
+source=(
+ 'https://github.com/JohannesBuchner/DHCProbe'
+)
+sha256sums=(
+ 'SKIP'
+)
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./autogen.sh
+ ./configure
+ make
+ make install
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm644 "$pkgname" "$pkgdir/usr/bin"
+}