summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2016-06-14 11:51:44 +0800
committerYen Chi Hsuan2016-06-14 11:51:44 +0800
commit389bf8f2fa9bdf5f365b9316a4100f89bd6709a6 (patch)
treee5de92a1cd7f91cecf96a5d6a9e355c2e6d0c81d
parent6cdbc98eb6fb8f626ca2a74eb99f7d768bd20395 (diff)
downloadaur-389bf8f2fa9bdf5f365b9316a4100f89bd6709a6.tar.gz
Bump and update depends
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD18
3 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53ddc3e5ad78..6947490cc3b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Tue Jun 14 03:51:30 UTC 2016
pkgbase = dhcptest-git
pkgdesc = DHCP test client
- pkgver = 0.5.r0.g56a8834
- pkgrel = 3
+ pkgver = 0.5.r11.g5bf3c44
+ pkgrel = 1
url = https://github.com/CyberShadow/dhcptest
arch = i686
arch = x86_64
@@ -9,7 +11,8 @@ pkgbase = dhcptest-git
makedepends = dmd
makedepends = git
depends = glibc
- source = dhcptest-git::git+https://github.com/CyberShadow/dhcptest
+ depends = gcc-libs
+ source = dhcptest::git+https://github.com/CyberShadow/dhcptest
source = http://www.boost.org/LICENSE_1_0.txt
md5sums = SKIP
md5sums = e4224ccaecb14d942c71d31bef20d78c
diff --git a/.gitignore b/.gitignore
index 43ff39c80917..ee37e1cbe1c9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,2 @@
LICENSE_1_0.txt
-# the cloned bare repo
-dhcptest-git
+/dhcptest/
diff --git a/PKGBUILD b/PKGBUILD
index 62ad6770be43..3c839fb3ea35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,33 @@
# Maintainer: Yen Chi Hsuan <yan12125 at gmail dot com>
-pkgname=dhcptest-git
-_github_addr=CyberShadow/dhcptest
-pkgver=0.5.r0.g56a8834
-pkgrel=3
+_pkgname=dhcptest
+pkgname=$_pkgname-git
+pkgver=0.5.r11.g5bf3c44
+pkgrel=1
pkgdesc="DHCP test client"
arch=('i686' 'x86_64')
url="https://github.com/CyberShadow/dhcptest"
license=('custom:BSL1.0')
-depends=('glibc')
+depends=('glibc' 'gcc-libs')
makedepends=('dmd' 'git')
-source=("$pkgname"::"git+https://github.com/$_github_addr"
+source=("$_pkgname"::"git+https://github.com/CyberShadow/dhcptest"
'http://www.boost.org/LICENSE_1_0.txt')
md5sums=('SKIP'
'e4224ccaecb14d942c71d31bef20d78c')
pkgver() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$_pkgname"
# Use the tag of the last commit
git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$_pkgname"
dmd dhcptest.d
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$_pkgname"
install -Dm755 "dhcptest" "$pkgdir/usr/bin/dhcptest"
install -Dm644 "README.md" "$pkgdir/usr/share/doc/dhcptest/README.md"
cd "$srcdir"