summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2019-02-28 18:20:48 +0100
committerGianluca Boiano2019-02-28 18:20:48 +0100
commit6d72320373d6e2c0c8005fe1aa5e75585fdd7a52 (patch)
treefc578f294949a9996142f82a335edd05ce4fbc29
parent061205e071f4a90a52b021f309630f9b266b2ed5 (diff)
downloadaur-6d72320373d6e2c0c8005fe1aa5e75585fdd7a52.tar.gz
dhewm3: doom3-data as optdepend and removed patch
-rw-r--r--.SRCINFO7
-rw-r--r--0001-game_data_location.patch11
-rw-r--r--PKGBUILD48
-rw-r--r--dhewm3.install8
4 files changed, 31 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8eff320fc63..b0b0840c3935 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,25 @@
pkgbase = dhewm3
pkgdesc = Doom 3 engine with native 64-bit support, SDL, and OpenAL
pkgver = 1.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dhewm/dhewm3
+ install = dhewm3.install
arch = i686
arch = x86_64
license = GPL3
makedepends = cmake
depends = curl
- depends = doom3-data
depends = libjpeg
depends = libvorbis
depends = openal
depends = sdl2
+ optdepends = doom3-data
source = https://github.com/dhewm/dhewm3/archive/1.5.0.tar.gz
source = dhewm3.desktop
source = dhewm3.png
- source = 0001-game_data_location.patch
md5sums = cc770a4e454704405a83d8ea170706e8
md5sums = 300636e2e3ac0566dc6ceb63f121850e
md5sums = 8b834c4c1cd5ccb25b1afe6cb47941a8
- md5sums = 27ac81efff2c25cd672979ea931c2cce
pkgname = dhewm3
diff --git a/0001-game_data_location.patch b/0001-game_data_location.patch
deleted file mode 100644
index fd8e18361285..000000000000
--- a/0001-game_data_location.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/neo/framework/Licensee.h 2018-12-15 05:49:59.000000000 +0100
-+++ b/neo/framework/Licensee.h 2019-02-27 14:11:12.516544799 +0100
-@@ -98,7 +98,7 @@
-
- // Linux info
- #ifndef LINUX_DEFAULT_PATH // allow overriding it from the build system with -DLINUX_DEFAULT_PATH="/bla/foo/whatever"
--#define LINUX_DEFAULT_PATH "/usr/local/games/doom3"
-+#define LINUX_DEFAULT_PATH "/usr/share/games/doom3"
- #endif
-
- // CD Key file info
diff --git a/PKGBUILD b/PKGBUILD
index 5e16bd8baa37..4e3ac09486e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,40 @@
# Maintainer: robertfoster
# Contributor: Mike Swanson <mikeonthecomputer@gmail.com>
+# Contributor:
pkgname=dhewm3
pkgver=1.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Doom 3 engine with native 64-bit support, SDL, and OpenAL"
arch=('i686' 'x86_64')
url="https://github.com/dhewm/dhewm3"
license=('GPL3')
-depends=('curl' 'doom3-data' 'libjpeg' 'libvorbis' 'openal' 'sdl2')
+depends=('curl' 'libjpeg' 'libvorbis' 'openal' 'sdl2')
+optdepends=('doom3-data')
makedepends=('cmake')
source=("$url/archive/$pkgver.tar.gz"
- "$pkgname.desktop"
- "$pkgname.png"
-'0001-game_data_location.patch')
-
-prepare() {
- cd "$pkgname-$pkgver"
-
- for patch in ../*.patch; do
- if [ ! -f "$patch" ]; then
- break;
- else
- patch -p1 -i "$patch"
- fi
- done
-}
+ "$pkgname.desktop"
+ "$pkgname.png"
+)
+install=$pkgname.install
build() {
- cd "$pkgname-$pkgver/neo"
-
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DD3XP=1 -DDEDICATED=1 .
- make
+ cd "$pkgname-$pkgver/neo"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DD3XP=1 \
+ -DDEDICATED=1 .
+ make
}
package() {
- cd "$pkgname-$pkgver/neo"
+ cd "$pkgname-$pkgver/neo"
- make DESTDIR="$pkgdir" libdir="$pkgdir/usr/lib" install
- install -Dm644 ../../$pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm644 ../../$pkgname.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ make DESTDIR="$pkgdir" libdir="$pkgdir/usr/lib" install
+ install -Dm644 ../../$pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 ../../$pkgname.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
}
md5sums=('cc770a4e454704405a83d8ea170706e8'
- '300636e2e3ac0566dc6ceb63f121850e'
- '8b834c4c1cd5ccb25b1afe6cb47941a8'
-'27ac81efff2c25cd672979ea931c2cce')
+ '300636e2e3ac0566dc6ceb63f121850e'
+'8b834c4c1cd5ccb25b1afe6cb47941a8')
diff --git a/dhewm3.install b/dhewm3.install
new file mode 100644
index 000000000000..32d1f2e7930e
--- /dev/null
+++ b/dhewm3.install
@@ -0,0 +1,8 @@
+post_install() {
+ cat <<MSG
+You have to copy the Doom 3 *.pk4 files to /usr/share/dhewm3.
+
+If you have Doom 3: Resurrection of Evil, you may also copy its
+*.pk4 files into the d3xp directory.
+MSG
+}