summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2012-12-03 08:41:29 -0800
committerMike Swanson2012-12-03 08:41:29 -0800
commit091f517b20ff5d966b73d554f9cfc178fa288693 (patch)
treedcc9c1f5fcf2dc025ecae56d6796f0e9736a7932
downloadaur-091f517b20ff5d966b73d554f9cfc178fa288693.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--0001-game_data_location.patch13
-rw-r--r--PKGBUILD49
-rw-r--r--dhewm3.desktop7
-rw-r--r--dhewm3.install6
6 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..907e7a19940f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = dhewm3-git
+ pkgdesc = Doom 3 engine with native 64-bit support, SDL, and OpenAL
+ pkgver = 20120703
+ pkgrel = 1
+ url = https://github.com/dhewm/dhewm3
+ install = dhewm3.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ depends = doom3-data
+ depends = libjpeg
+ depends = libogg
+ depends = libvorbis
+ depends = openal
+ depends = sdl
+ optdepends = curl: download support
+ source = dhewm3.desktop
+ source = 0001-game_data_location.patch
+ sha256sums = 7c9ae892c6cf0453fcd57731689ccedac8f8ce10f33043f7dd5fb66bd73d1287
+ sha256sums = 285b91bd3ec936382f21a5b047256d730dfea7a6a9ee30bfb5a99d3d41060d3a
+
+pkgname = dhewm3-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d727fb45d4db
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar*
+*.src.tar*
+src
+pkg
diff --git a/0001-game_data_location.patch b/0001-game_data_location.patch
new file mode 100644
index 000000000000..1575038025e3
--- /dev/null
+++ b/0001-game_data_location.patch
@@ -0,0 +1,13 @@
+diff --git a/neo/framework/Licensee.h b/neo/framework/Licensee.h
+index 9cc20fb..fb1c882 100644
+--- a/neo/framework/Licensee.h
++++ b/neo/framework/Licensee.h
+@@ -90,7 +90,7 @@ If you have questions concerning this license or the applicable additional terms
+ #define WIN32_CONSOLE_CLASS "dhewm 3 WinConsole"
+
+ // Linux info
+-#define LINUX_DEFAULT_PATH "/usr/local/games/doom3"
++#define LINUX_DEFAULT_PATH "/usr/share/doom3"
+
+ // CD Key file info
+ // goes into BASE_GAMEDIR whatever the fs_game is set to
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10ecaee02db9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
+pkgname=dhewm3-git
+pkgver=20120703
+pkgrel=1
+pkgdesc="Doom 3 engine with native 64-bit support, SDL, and OpenAL"
+arch=('i686' 'x86_64')
+url="https://github.com/dhewm/dhewm3"
+license=('GPL3')
+depends=('doom3-data' 'libjpeg' 'libogg' 'libvorbis' 'openal' 'sdl')
+makedepends=('cmake' 'git')
+optdepends=('curl: download support')
+install=dhewm3.install
+source=('dhewm3.desktop'
+ '0001-game_data_location.patch')
+sha256sums=('7c9ae892c6cf0453fcd57731689ccedac8f8ce10f33043f7dd5fb66bd73d1287'
+ '285b91bd3ec936382f21a5b047256d730dfea7a6a9ee30bfb5a99d3d41060d3a')
+
+_gitroot=git://github.com/dhewm/dhewm3.git
+_gitname=dhewm3
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ cd "$srcdir/$_gitname"
+ patch -p1 < "$srcdir"/0001-game_data_location.patch
+
+ cd neo
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DD3XP=1 -DDEDICATED=1 .
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname/neo"
+
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${srcdir}"/dhewm3.desktop "$pkgdir"/usr/share/applications/dhewm3.desktop
+}
diff --git a/dhewm3.desktop b/dhewm3.desktop
new file mode 100644
index 000000000000..15f0be3eb663
--- /dev/null
+++ b/dhewm3.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Dhewm3
+Exec=dhewm3
+Icon=doom3
+Type=Application
+Comment=A Doom 3 port
+Categories=Game;ActionGame;
diff --git a/dhewm3.install b/dhewm3.install
new file mode 100644
index 000000000000..99f4e6fb51cb
--- /dev/null
+++ b/dhewm3.install
@@ -0,0 +1,6 @@
+post_upgrade() {
+ cat <<EOF
+Dhewm3 has moved its user configuration. To smoothly upgrade, copy or
+move ~/.doom3 to ~/.config/dhewm3.
+EOF
+}