summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2015-09-30 10:07:14 -0700
committerMike Swanson2015-09-30 10:07:14 -0700
commit38e3ad5566748317112f9ae4a4a2931523d4fbbe (patch)
treee91a16adb06f68e57c8944cdf28b7ce8ea34d76d
parent86b1ccef3d2959cfedca685e9fe7117d29f2634c (diff)
downloadaur-38e3ad5566748317112f9ae4a4a2931523d4fbbe.tar.gz
Remove basepatch patch, update versioning standards
-rw-r--r--.SRCINFO7
-rw-r--r--0002-find_basepath_correctly.patch36
-rw-r--r--PKGBUILD24
3 files changed, 18 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92f49179bd1f..7ecc63db1dc2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = dhewm3-git
pkgdesc = Doom 3 engine with native 64-bit support, SDL, and OpenAL
- pkgver = 2015.03.22.g657ad99
+ pkgver = r482.61d3efe
pkgrel = 1
+ epoch = 1
url = https://github.com/dhewm/dhewm3
arch = i686
arch = x86_64
@@ -15,14 +16,12 @@ pkgbase = dhewm3-git
depends = openal
depends = sdl
optdepends = curl: download support
- source = git+https://github.com/dhewm/dhewm3.git
+ source = git+https://github.com/dhewm/dhewm3
source = dhewm3.desktop
source = 0001-game_data_location.patch
- source = 0002-find_basepath_correctly.patch
sha256sums = SKIP
sha256sums = 7c9ae892c6cf0453fcd57731689ccedac8f8ce10f33043f7dd5fb66bd73d1287
sha256sums = dbbb0607a92482a1b753cf9cac97dcc57345b92ee43449c9826f5b23af7624f9
- sha256sums = 41ea4db22a8a884a2ce9b6c8e68dc2e0364a02528eda2bec81e4a90b9c322557
pkgname = dhewm3-git
diff --git a/0002-find_basepath_correctly.patch b/0002-find_basepath_correctly.patch
deleted file mode 100644
index a3151a5aec99..000000000000
--- a/0002-find_basepath_correctly.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff --git a/neo/sys/linux/main.cpp b/neo/sys/linux/main.cpp
-index d4b52b0..9b77c36 100644
---- a/neo/sys/linux/main.cpp
-+++ b/neo/sys/linux/main.cpp
-@@ -62,6 +62,16 @@ bool Sys_GetPath(sysPath_t type, idStr &path) {
-
- common->Warning("base path '" BUILD_DATADIR "' does not exist");
-
-+ // fallback to vanilla doom3 install
-+ if (stat(LINUX_DEFAULT_PATH, &st) != -1 && S_ISDIR(st.st_mode)) {
-+ common->Warning("using hardcoded default base path");
-+
-+ path = LINUX_DEFAULT_PATH;
-+ return true;
-+ }
-+
-+ common->Warning("base path '" LINUX_DEFAULT_PATH "' does not exist");
-+
- // try next to the executable..
- if (Sys_GetPath(PATH_EXE, path)) {
- path = path.StripFilename();
-@@ -73,14 +83,6 @@ bool Sys_GetPath(sysPath_t type, idStr &path) {
- }
- }
-
-- // fallback to vanilla doom3 install
-- if (stat(LINUX_DEFAULT_PATH, &st) != -1 && S_ISDIR(st.st_mode)) {
-- common->Warning("using hardcoded default base path");
--
-- path = LINUX_DEFAULT_PATH;
-- return true;
-- }
--
- return false;
-
- case PATH_CONFIG:
diff --git a/PKGBUILD b/PKGBUILD
index da682c67b1a8..4f8c6101e090 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
pkgname=dhewm3-git
-pkgver=2015.03.22.g657ad99
+pkgver=r482.61d3efe
pkgrel=1
+epoch=1
pkgdesc="Doom 3 engine with native 64-bit support, SDL, and OpenAL"
arch=('i686' 'x86_64')
url="https://github.com/dhewm/dhewm3"
@@ -9,24 +10,29 @@ license=('GPL3')
depends=('doom3-data' 'libjpeg' 'libogg' 'libvorbis' 'openal' 'sdl')
makedepends=('cmake' 'git')
optdepends=('curl: download support')
-source=("git+$url.git"
+source=("git+$url"
'dhewm3.desktop'
- '0001-game_data_location.patch'
- '0002-find_basepath_correctly.patch')
+ '0001-game_data_location.patch')
sha256sums=('SKIP'
'7c9ae892c6cf0453fcd57731689ccedac8f8ce10f33043f7dd5fb66bd73d1287'
- 'dbbb0607a92482a1b753cf9cac97dcc57345b92ee43449c9826f5b23af7624f9'
- '41ea4db22a8a884a2ce9b6c8e68dc2e0364a02528eda2bec81e4a90b9c322557')
+ 'dbbb0607a92482a1b753cf9cac97dcc57345b92ee43449c9826f5b23af7624f9')
pkgver() {
cd "${pkgname/-git/}"
- git log -1 --format="%cd.g%h" --date=short | sed 's/-/./g'
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
cd "${pkgname/-git/}"
- patch -p1 < "$srcdir"/0001-game_data_location.patch
- patch -p1 < "$srcdir"/0002-find_basepath_correctly.patch
+
+ for patch in ../*.patch; do
+ if [ ! -f "$patch" ]; then
+ break;
+ else
+ patch -p1 -i "$patch"
+ fi
+ done
}
build() {