summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2015-06-10 09:00:39 -0700
committerMike Swanson2015-06-10 09:00:39 -0700
commit86b1ccef3d2959cfedca685e9fe7117d29f2634c (patch)
tree667e2127d8eaf67277f26c517f1a084a77aeb8bd
parentb6b062ef703556dcdd93277e6f1b98ba8ca4cdbd (diff)
downloadaur-86b1ccef3d2959cfedca685e9fe7117d29f2634c.tar.gz
Update packaging standards, use CMAKE_INSTALL_LIBDIR
Also remove the upgrade note. Been over two years, time to go.
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD19
-rw-r--r--dhewm3.install6
4 files changed, 13 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea728a413363..92f49179bd1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = dhewm3-git
pkgdesc = Doom 3 engine with native 64-bit support, SDL, and OpenAL
- pkgver = 2013.09.17.g6d8108c
- pkgrel = 2
+ pkgver = 2015.03.22.g657ad99
+ pkgrel = 1
url = https://github.com/dhewm/dhewm3
- install = dhewm3.install
arch = i686
arch = x86_64
license = GPL3
diff --git a/.gitignore b/.gitignore
index d727fb45d4db..2c476a25b66b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.pkg.tar*
*.src.tar*
+/dhewm3/
src
pkg
diff --git a/PKGBUILD b/PKGBUILD
index 1e9a323e21ba..da682c67b1a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
pkgname=dhewm3-git
-pkgver=2013.09.17.g6d8108c
-pkgrel=2
+pkgver=2015.03.22.g657ad99
+pkgrel=1
pkgdesc="Doom 3 engine with native 64-bit support, SDL, and OpenAL"
arch=('i686' 'x86_64')
url="https://github.com/dhewm/dhewm3"
@@ -9,8 +9,7 @@ license=('GPL3')
depends=('doom3-data' 'libjpeg' 'libogg' 'libvorbis' 'openal' 'sdl')
makedepends=('cmake' 'git')
optdepends=('curl: download support')
-install=dhewm3.install
-source=('git+https://github.com/dhewm/dhewm3.git'
+source=("git+$url.git"
'dhewm3.desktop'
'0001-game_data_location.patch'
'0002-find_basepath_correctly.patch')
@@ -24,20 +23,22 @@ pkgver() {
git log -1 --format="%cd.g%h" --date=short | sed 's/-/./g'
}
-build() {
+prepare() {
cd "${pkgname/-git/}"
patch -p1 < "$srcdir"/0001-game_data_location.patch
patch -p1 < "$srcdir"/0002-find_basepath_correctly.patch
+}
- cd neo
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DD3XP=1 -DDEDICATED=1 .
+build() {
+ cd "${pkgname/-git/}/neo"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DD3XP=1 -DDEDICATED=1 .
make
}
package() {
cd "${pkgname/-git/}/neo"
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="$pkgdir" libdir="$pkgdir/usr/lib" install
- install -Dm644 "${srcdir}"/dhewm3.desktop "$pkgdir"/usr/share/applications/dhewm3.desktop
+ install -Dm644 "$srcdir"/dhewm3.desktop "$pkgdir/usr/share/applications/dhewm3.desktop"
}
diff --git a/dhewm3.install b/dhewm3.install
deleted file mode 100644
index 99f4e6fb51cb..000000000000
--- a/dhewm3.install
+++ /dev/null
@@ -1,6 +0,0 @@
-post_upgrade() {
- cat <<EOF
-Dhewm3 has moved its user configuration. To smoothly upgrade, copy or
-move ~/.doom3 to ~/.config/dhewm3.
-EOF
-}