summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-08-29 11:53:49 -0400
committerSolomon Choina2018-08-29 11:53:49 -0400
commit0b4fa1b96f9da8ac3ec988c338d108598e8bc774 (patch)
tree77a9d004188782d7461fbebfa1eeef90df81feea
parent9b7d4130f56282345c2d6020c506bf6eedff2e5c (diff)
downloadaur-0b4fa1b96f9da8ac3ec988c338d108598e8bc774.tar.gz
adding the libraries
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2548396898a..c7c9e9e39940 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
-# Generated by mksrcinfo v8
-# Mon Feb 5 20:23:02 UTC 2018
pkgbase = dht
pkgdesc = BitTorrent DHT library
pkgver = 0.24
- pkgrel = 1
- url = https://github.com/jech/dht
+ pkgrel = 2
+ url = https://github.com/transmission/dht.git
arch = i686
arch = x86_64
license = MIT
- source = https://raw.githubusercontent.com/jech/dht/master/dht.h
- sha256sums = 4c03ab71da7f7b76331a5b625fe4cd1bc9b1f58039b48bf2ceb6b47f1353bd48
+ source = git+https://github.com/transmission/dht.git#branch=post-0.24-transmission
+ sha256sums = SKIP
pkgname = dht
diff --git a/PKGBUILD b/PKGBUILD
index 27a23cda5240..ed0180db6639 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,21 @@
# Maintainer: Solomon Choina <shlomochoina@gmail.com>
pkgname=dht
pkgver=0.24
-pkgrel=1
+pkgrel=2
pkgdesc="BitTorrent DHT library"
arch=('i686' 'x86_64')
-url="https://github.com/jech/dht"
+url="https://github.com/transmission/dht.git"
license=('MIT')
-source=(https://raw.githubusercontent.com/jech/dht/master/dht.h)
-sha256sums=('4c03ab71da7f7b76331a5b625fe4cd1bc9b1f58039b48bf2ceb6b47f1353bd48')
+source=("git+$url#branch=post-0.24-transmission")
+sha256sums=('SKIP')
+build() {
+ cd $srcdir/dht
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
package() {
+ cd $srcdir/dht
+ make DESTDIR=$pkgdir install
install -D dht.h "${pkgdir}"/usr/include/dht/dht.h
}