summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam S Levy2018-03-18 23:28:36 -0800
committerAdam S Levy2018-03-18 23:28:36 -0800
commit26eb9e6f6cb7131c24c6782e5b3a92553a350fbf (patch)
tree9223e6691148309a1c9822148d276c8c3019a3e9
downloadaur-26eb9e6f6cb7131c24c6782e5b3a92553a350fbf.tar.gz
Initial commit version 2.12
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD18
3 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cc5794ebcf6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = diagslave-bin
+ pkgdesc = A simple command line based Modbus slave simulator and test utility.
+ pkgver = 2.12
+ pkgrel = 1
+ url = https://www.modbusdriver.com/diagslave.html
+ arch = x86_64
+ license = custom
+ provides = diagslave
+ source = https://www.modbusdriver.com/downloads/diagslave.2.12.zip
+ md5sums = 7b9584b56d2ab2641ca4affcdb00f19f
+
+pkgname = diagslave-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7dd436b1ae6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=diagslave-bin
+_pkgname=diagslave
+pkgver=2.12
+pkgrel=1
+pkgdesc="A simple command line based Modbus slave simulator and test utility."
+arch=("x86_64")
+url="https://www.modbusdriver.com/diagslave.html"
+license=('custom')
+provides=("$_pkgname")
+source=("https://www.modbusdriver.com/downloads/diagslave.2.12.zip")
+md5sums=('7b9584b56d2ab2641ca4affcdb00f19f')
+
+package() {
+ cd "$srcdir"
+ install -Dm755 linux/diagslave "$pkgdir/usr/bin/diagslave"
+ install -Dm644 LICENSE-FREE "$pkgdir/usr/share/licenses/diagslave/LICENSE"
+}