summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2022-07-11 16:13:43 +0200
committerhaawda2022-07-11 16:13:43 +0200
commitf81cfd9554f2a7330340cb7d5db2cf9ea130dc13 (patch)
treecdd4c11f3ad6180809c44b4243b338c28e7990fc
parentc4f6aafeb77876209a6d47f4d166cce2aacdd53a (diff)
downloadaur-f81cfd9554f2a7330340cb7d5db2cf9ea130dc13.tar.gz
update, pull from sourcehut
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4301fd95c1ca..c5a6daf18601 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = diakonos
pkgdesc = A Linux editor for the masses.
- pkgver = 0.9.7
- pkgrel = 2
- url = http://github.com/Pistos/diakonos
+ pkgver = 0.9.8
+ pkgrel = 1
+ url = https://git.sr.ht/~pistos/diakonos
arch = any
license = MIT
+ makedepends = git
depends = ruby-curses
- source = diakonos-0.9.7.tar.gz::https://github.com/Pistos/diakonos/archive/v0.9.7.tar.gz
- sha256sums = 77b7f2d2ba29c3a72fff85c91038e19c40eef8a162945105bad203c065c554f9
+ source = git+https://git.sr.ht/~pistos/diakonos#commit=5f064a5d439b545d7eea360caef2b40114dd294b
+ sha256sums = SKIP
pkgname = diakonos
-
diff --git a/PKGBUILD b/PKGBUILD
index d55cccc45b80..5ec0d08411b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,24 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=diakonos
-pkgver=0.9.7
-pkgrel=2
+pkgver=0.9.8
+pkgrel=1
pkgdesc="A Linux editor for the masses."
arch=('any')
depends=('ruby-curses')
+makedepends=('git')
license=('MIT')
-url="http://github.com/Pistos/diakonos"
-source=("$pkgname-$pkgver.tar.gz::https://github.com/Pistos/diakonos/archive/v$pkgver.tar.gz")
-sha256sums=('77b7f2d2ba29c3a72fff85c91038e19c40eef8a162945105bad203c065c554f9')
+url="https://git.sr.ht/~pistos/diakonos"
+source=("git+$url#commit=5f064a5d439b545d7eea360caef2b40114dd294b")
+sha256sums=('SKIP')
prepare() {
- cd $pkgname-$pkgver
+ cd $pkgname
sed -i 's+sitelibdir+vendorlibdir+' install.rb
}
package() {
- cd $pkgname-$pkgver
+ cd $pkgname
ruby install.rb --dest-dir $pkgdir --prefix /usr --conf-dir /etc
install -D -m644 LICENCE "$pkgdir"/usr/share/licenses/$pkgname/MIT
}