summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-06-28 10:14:01 +0200
committeraksr2015-06-28 10:14:01 +0200
commit573d2eaea1b364c9e49156e5b4d05839f9fbaea3 (patch)
tree98ddb20c9bc1056c7d7fe9b0fd507338cbaaba57
downloadaur-573d2eaea1b364c9e49156e5b4d05839f9fbaea3.tar.gz
Start.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e4c16acaddb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = diakonos-git
+ pkgdesc = A Linux console text editor for the masses.
+ pkgver = 0.9.1.r61.gc0eadfe
+ pkgrel = 1
+ url = http://diakonos.pist0s.ca/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = ruby
+ depends = ruby-curses
+ provides = diakonos
+ conflicts = diakonos
+ source = diakonos-git::git+https://github.com/Pistos/diakonos.git
+ md5sums = SKIP
+
+pkgname = diakonos-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..193a8be351d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=diakonos-git
+pkgver=0.9.1.r61.gc0eadfe
+pkgrel=1
+pkgdesc="A Linux console text editor for the masses."
+arch=('i686' 'x86_64')
+url="http://diakonos.pist0s.ca/"
+license=('MIT')
+groups=()
+depends=('ruby' 'ruby-curses')
+makedepends=('git')
+optdepends=()
+provides=('diakonos')
+conflicts=('diakonos')
+replaces=()
+backup=()
+options=()
+install=
+source=("$pkgname::git+https://github.com/Pistos/diakonos.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^v//g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ ruby=$(test -x /usr/bin/ruby && echo /usr/bin/ruby || which ruby)
+ $ruby install.rb --dest-dir $pkgdir --prefix /usr --conf-dir /etc
+ install -Dm644 LICENCE $pkgdir/usr/share/licenses/diakonos/LICENCE
+}
+