summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-09-07 09:22:13 -0600
committerMark Wagie2021-09-07 09:22:13 -0600
commit51ef970417e880c51a0425746f84e21ea0ccd7ea (patch)
tree90f20855950c6f9b9f4c763215da04fc659a82c8
parentd182d59f66e17c94126dad8300977010326ee75e (diff)
downloadaur-51ef970417e880c51a0425746f84e21ea0ccd7ea.tar.gz
add submodule
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD59
3 files changed, 47 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a66be6a4200..bd9802d4b7fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,26 @@
pkgbase = dialect
- pkgdesc = A translation app for GNOME based on Google Translate
+ pkgdesc = A translation app for GNOME.
pkgver = 1.3.0
- pkgrel = 1
- url = https://github.com/gi-lom/dialect
+ pkgrel = 2
+ url = https://github.com/dialect-app/dialect
arch = any
license = GPL3
- makedepends = gobject-introspection
+ checkdepends = appstream-glib
makedepends = meson
+ makedepends = git
+ makedepends = gobject-introspection
depends = gtk3
- depends = gst-python
depends = libhandy
- depends = python
depends = python-gobject
depends = python-googletrans
depends = python-gtts
- depends = python-h2
depends = python-httpx
- source = dialect-v1.3.0.tar.gz::https://github.com/gi-lom/dialect/archive/1.3.0.tar.gz
- sha256sums = c5f11de1c3067d05bd81a8964ec40a9c6334c6772069c61f999f719d5e36cbae
+ depends = gst-python
+ conflicts = gnabel
+ replaces = gnabel
+ source = git+https://github.com/dialect-app/dialect.git#tag=1.3.0
+ source = git+https://github.com/dialect-app/po.git
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = dialect
-
diff --git a/.gitignore b/.gitignore
index b73905529f23..4dab8d6386e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,13 +1,7 @@
-*.tar
-*.tar.*
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
+# Ignore everything
+*
-pkg/
-src/
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 3e2d12cbc3f6..6db9d944aeca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,39 @@
-# Maintainer: Mufeed Ali <lastweakness@tuta.io>
-
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Mufeed Ali <lastweakness@tuta.io>
pkgname=dialect
-_author=gi-lom
-_gitname=dialect
pkgver=1.3.0
-pkgrel=1
-pkgdesc='A translation app for GNOME based on Google Translate'
-arch=(any)
-url=https://github.com/gi-lom/dialect
-license=(GPL3)
-depends=(
- gtk3
- gst-python
- libhandy
- python
- python-gobject
- python-googletrans
- python-gtts
- python-h2
- python-httpx
-)
-makedepends=(
- gobject-introspection
- meson
-)
-source=("$_gitname-v$pkgver.tar.gz::https://github.com/$_author/$_gitname/archive/$pkgver.tar.gz")
-sha256sums=('c5f11de1c3067d05bd81a8964ec40a9c6334c6772069c61f999f719d5e36cbae')
+pkgrel=2
+pkgdesc="A translation app for GNOME."
+arch=('any')
+url="https://github.com/dialect-app/dialect"
+license=('GPL3')
+depends=('gtk3' 'libhandy' 'python-gobject' 'python-googletrans' 'python-gtts'
+ 'python-httpx' 'gst-python')
+makedepends=('meson' 'git' 'gobject-introspection')
+checkdepends=('appstream-glib')
+conflicts=('gnabel')
+replaces=('gnabel')
+source=("git+https://github.com/dialect-app/dialect.git#tag=$pkgver"
+ 'git+https://github.com/dialect-app/po.git')
+sha256sums=('SKIP'
+ 'SKIP')
prepare() {
- cd $_gitname-$pkgver
- cd ..
+ cd "$srcdir/$pkgname"
+ git submodule init
+ git config submodule.po.url $srcdir/po
+ git submodule update
}
build() {
- arch-meson $_gitname-$pkgver build
- ninja -C build
+ arch-meson "$pkgname" build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
}
package() {
- DESTDIR="${pkgdir}" ninja -C build install
+ DESTDIR="$pkgdir" meson install -C build
}