summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMufeed Ali2020-10-15 09:28:21 +0530
committerMufeed Ali2020-10-15 09:28:21 +0530
commit6c87aa20437bcc29d8a6cc06e1791cc68662667c (patch)
treedc8061460744c96ce2796a7ba849054be112a6b3
downloadaur-6c87aa20437bcc29d8a6cc06e1791cc68662667c.tar.gz
Initial release
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD40
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72af5527c7bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = dialect
+ pkgdesc = A translation app for GNOME based on Google Translate
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/gi-lom/dialect
+ arch = any
+ license = GPL3
+ makedepends = gobject-introspection
+ makedepends = meson
+ depends = gtk3
+ depends = gst-python
+ depends = libhandy
+ depends = python
+ depends = python-gobject
+ depends = python-googletrans
+ depends = python-gtts
+ source = dialect-1.0.0.tar.gz::https://github.com/gi-lom/dialect/archive/1.0.0.tar.gz
+ sha256sums = 6dc6599905d2a376d99a8cff3ef64c93b1b7b99d84f7850dfe56313ebc5883e6
+
+pkgname = dialect
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..199cb5145124
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src
+*.py
+*.tar.gz
+*.pkg*
+pkg/*
+/.project
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c660ec70abea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Mufeed Ali <lastweakness@tuta.io>
+
+pkgname=dialect
+_author=gi-lom
+_gitname=dialect
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='A translation app for GNOME based on Google Translate'
+arch=(any)
+url=https://github.com/gi-lom/dialect
+license=(GPL3)
+depends=(
+ gtk3
+ gst-python
+ libhandy
+ python
+ python-gobject
+ python-googletrans
+ python-gtts
+)
+makedepends=(
+ gobject-introspection
+ meson
+)
+source=("$_gitname-$pkgver.tar.gz::https://github.com/$_author/$_gitname/archive/$pkgver.tar.gz")
+sha256sums=('6dc6599905d2a376d99a8cff3ef64c93b1b7b99d84f7850dfe56313ebc5883e6')
+
+prepare() {
+ cd $_gitname-$pkgver
+ cd ..
+}
+
+build() {
+ arch-meson $_gitname-$pkgver build
+ ninja -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+}