summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-20 14:05:15 -0700
committerMark Wagie2024-01-20 14:05:15 -0700
commitfa30ea71285e4bf31c034c773b3697450c818bdc (patch)
treec64f9387a23a97aefd0e010cdd5634234a804d36
parentb0662ae59dcc5e8a8bb50de8d35795430a9dda8e (diff)
downloadaur-fa30ea71285e4bf31c034c773b3697450c818bdc.tar.gz
use SPDX license identifier
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1366932b6df3..bf036d1dad12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = dialect
pkgrel = 1
url = https://apps.gnome.org/Dialect
arch = any
- license = GPL3
+ license = GPL-3.0-or-later
checkdepends = appstream-glib
makedepends = blueprint-compiler
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 9df22f43879f..e33aa7ef559f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,23 +6,23 @@ pkgrel=1
pkgdesc="A translation app for GNOME."
arch=('any')
url="https://apps.gnome.org/Dialect"
-license=('GPL3')
+license=('GPL-3.0-or-later')
depends=('dbus-python' 'gst-python' 'libadwaita' 'libsoup3' 'python-gobject' 'python-gtts')
makedepends=('blueprint-compiler' 'git' 'gobject-introspection' 'meson')
checkdepends=('appstream-glib')
-_commit=93ad6c170363ff2c3d27c7f72eb5c67ffff85188 #tags/2.2.0^0
+_commit=93ad6c170363ff2c3d27c7f72eb5c67ffff85188 # tags/2.2.0^0
source=("git+https://github.com/dialect-app/dialect.git#commit=$_commit"
'git+https://github.com/dialect-app/po.git')
sha256sums=('SKIP'
'SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
+ cd "$pkgname"
git describe --tags | sed 's/-/+/g'
}
prepare() {
- cd "$srcdir/$pkgname"
+ cd "$pkgname"
git submodule init
git config submodule.po.url "$srcdir/po"
git -c protocol.file.allow=always submodule update