summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAzat Abdullin2017-06-23 15:44:41 +0000
committerAzat Abdullin2017-06-23 15:44:41 +0000
commitfc4d117673b108dead9c55e839df341d85518b91 (patch)
tree37d115771c82c484fe7aa6cf351557985f873ef9
downloadaur-fc4d117673b108dead9c55e839df341d85518b91.tar.gz
Init
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD29
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5543c40ea619
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Fri Jun 23 15:44:32 UTC 2017
+pkgbase = dialer-phonepi
+ pkgdesc = Dialer application and call daemon for PhonePi project
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/PhonePi
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ depends = qt5-base
+ depends = qt5-tools
+ depends = glib2
+ depends = dbus
+ depends = dbus-glib
+ source = git://github.com/PhonePi/phonepi.git
+ sha256sums = SKIP
+
+pkgname = dialer-phonepi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..367a739e2602
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=dialer-phonepi
+pkgver=1
+pkgrel=1
+pkgdesc="Dialer application and call daemon for PhonePi project"
+url="https://github.com/PhonePi"
+arch=("i686" "x86_64" "armv6h")
+license=("GPL2")
+makedepends=("git" "cmake")
+depends=("qt5-base" "qt5-tools" "glib2" "dbus" "dbus-glib")
+source=(git://github.com/PhonePi/phonepi.git)
+sha256sums=("SKIP")
+
+build() {
+ cd "$srcdir/phonepi/src/phone/daemon"
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make
+
+ cd "$srcdir/phonepi/src/phone/qt"
+ qmake
+ make
+}
+
+package() {
+ cd "$srcdir/phonepi/src/phone/daemon"
+ make DESTDIR=$pkgdir install
+
+ cd "$srcdir/phonepi/src/phone/qt"
+ make DESTDIR=$pkgdir install
+}